Wrong resolution

Installed 11, and after booting the default desktop resolution and refresh rate are not the ones I want. There is no way to use the kde control center to set it because it reports that my randr version is at 1.2 or greater which has no configuration yet on an otherwise empty gray page for the display size and orientation.

I can set the resolution and refresh by placing the randr applet in the system tray, but after reboot it goes back the way it was.

Is there other way I can get to this setting so I can set my resolution and refresh rate and have it retain that setting across boots?

Does editing /etc/X11/xorg.conf keep things permanent?

Well, I found an entry called preferredmode under a section called monitor in xorg.conf and it was set to 1280X1024. This is what it is booting up with by default, but I changed the setting and it stayed at 1280 though.

Look in Yast at Sax2 which is located as Yast → hardware → Graphics card & monitor. Look under (1) monitor → change → frequencies and of course (2) resolution drop-down list

There are frequencies there, but no resolution dropdown list.

Sounds a bit like it hasn’t detected the video card correctly. Is the card reported in the Sax2 configuration screen card?

No, It’s there and so is the monitor. It behaves the same way with the Radeon driver and the ATI proprietary driver.

I don’t believe it has anything to do with the card or the driver.

This was a common problem in 10.3 as far as I could tell but I never found out the solution. I found a workaround by using the kconfiguration editor to set the default resolution and refresh rate but I can’t find the setting I used in 10.3 in the one in 11.

i’ve dealt with the resolution oddity since 10.3 as well. for some reason(for me) xorg.conf is coming up with an empty mode section. what i did for 10.3 was copy the mode and monitor section from 10.2’s xorg.conf where i had it working properly into 10.3’s. i had to do the same thing for 11.0. anybody have any idea why there would be no modelines? i know i’ve seen the prob mentioned somewhere but not the solution.

my configuration is gf 7600gt + 1280x768 + 173.14.09 + x86

My modes section is definitely not empty and I don’t have a 10.2 or 10.3 xorg.conf anymore.

Are you saying that putting a 10.2 xorg.conf into 10.3 gave you the size and orientation controls on the display properties page in the Kde control center?


no, the error is still there. i’m just saying that before i copied the lines in, no changes i made in any GUI ever worked properly (from kde, sax2 or nvidia x server settings).

just mentioning it in case it was relevant to your case.

I see. Thanks. No, I can change my rez and refresh with the randr applet in the tray. I just can’t make it stick across boots.