Wrong refresh rate ofIiyama Vision Master 1452 on ATI HD4850


I recently installed OpenSuse 11.1 on my PC with ATI HD4850 and Iiyama Visionmaster 1451 CRT. For some reason, I am unable to select any refresh rate higher than 60 Hz in any mode using Desktop settings, or using VertRefresh settings in xorg.conf. Incidentally, the hor. and vert. refresh rate in xorg.conf are identical to those specified by the manufacturer.

Also xrandr -q shows all modes as 60Hz only.

How can I change this?

As it’s a CRT, if you lower the resolution you get higher refresh rate options?

I vaguely remember that with CRT’s there’s a trade-off between resolution an refresh rate, so that at maximum resolution you only get the lowest refresh rate, usually 60 Hz (or 50 Hz in really, really old monitors).

Check your monitor specs, the info should be there. In an off-chance, also check the maximum output your video card can deliver.

From what I managed to trawl from Google, this monitor is capable of Max Resolution 1600 x 1200 @ 76 Hz. Usually, it is just a matter of selecting the correct monitor via sax2. Sometimes, a generic CRT monitor of similar specs has to be selected. If this doesn’t work for your monitor, then the manual method is to add a modeline to xorg.conf with some help from gtf:

dean@linux:~> gtf 1600 1200 75

1600x1200 @ 75.00 Hz (GTF) hsync: 93.97 kHz; pclk: 205.99 MHz

Modeline “1600x1200_75.00” 205.99 1600 1720 1896 2192 1200 1201 1204 1253 -HSync +Vsync

Then edit the relevant sections of xorg.conf:

Section “Monitor”
Option “PreferredMode” “1600x1200_75.00”

Section “Modes”
Identifier “Modes[0]”
Modeline “1600x1200_75.00” 205.99 1600 1720 1896 2192 1200 1201 1204 1253 -HSync +Vsync

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1600x1200_75.00”


I had already tried this, it does not work. In fact, it even messes up the screen. Do you have any other ideas? I am beginning to think something in my installation is messed up.

What video driver did 11.1 select at install, and what driver is specified in your xorg.conf?

Yes, maybe you should give us the output of

/usr/sbin/hwinfo --gfxcard

For some strange reason I have a new phenomenon now: after SaX has started xserver all I see is a cursor (not blinking) in a black screen. However, the system appears to be responding, because <Ctrl>+<Alt>+<Del> does perform a reboot. As far as I am aware of, I did not change anything in my configuration between the last time when xserver was correctly started and today…

In any case, I am able to login to console using the init 3 boot option. I was able to run hwinfo and the ouput is:

hwinfo --gfxcard
39: PCI 100.0 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_1002_9442
Unique ID: VCu0.U9gTB5UhXTE
Parent ID: _Znp.Qo1ZBBsCs1C
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI RV770 (RV770 9442)”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9442 “RV770 (RV770 9442)”
SubVendor: pci 0x1043 “ASUSTek Computer Inc.”
SubDevice: pci 0x026a
Driver: “fglrx_pci”
Driver Modules: “fglrx”
Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
Memory Range: 0xfbce0000-0xfbceffff (rw,non-prefetchable)
I/O Ports: 0xc000-0xcfff (rw)
Memory Range: 0xfbcc0000-0xfbcdffff (ro,prefetchable,disabled)
IRQ: 11 (2988 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009442sv00001043sd0000026Abc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: fglrx
Driver Info #1:
XFree86 v4 Server Module: fglrx
3D Support: yes
Extensions: dri
Config status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #21 (PCI bridge)

Primary display adapter: #39

To my uninitiated eye, it looks like the hardware is correctly identified.

If you haven’t already, have a look at /var/log/Xorg.0.log. It’s readable, and each start-up generates a new one. Notice the explanation of “Markers” in the first few lines. initially scan for any EE or WW messages. The log should show you if on probing, your monitor’s default modes are being detected. It will also show how modelines known to Xorg are being used or rejected.

If you want help with interpretation, you should post back here and include the relevant lines from your Xorg.0.log file.

I did as you suggested, but the xorg.0.log only contained the warning “Force AIGLX enabled” and no error messages.

Because I was at a loss how to find out what is wrong, I decided to reinstall Linux (as this was a not so time consuming option) and start from scratch. What I found is this:

  • After installing it is impossible to start SaX, it exits with the warnings “FW FB scratch area not located at end of VRAM”, “No outputs definitively connected” and “Unable to find initial modes”, and with the error " RadeonHD(0): RandR No valid modes".

  • I tried installing the latest ATI driver, using the build rpm method (see ATI installation manual), and then “rpm -Uvh fglrx*.rpm”. This fails however, with multiple warnings of (I write this down from memory) “Duplicate files” (or similar wording) and then listing all instances of Xfgrlx as duplicates for the ATI versions.

  • I tried removing the existing fglrx files with rpm -e, then rebuilding the kernel from source with the ATI drivers. This seems to succeed, however generated some warnings (about casts failing and unused variables, forgot to write it down). After initializing with “aticonfig --initial” and “sax2 -r -m 0=fglrx” and rebooting, sax succesfully starts the x server, however an error message pops up after boot complete “Application KWin crashed… likely due to a bug” (also from memory). After this, the screen looks displaced and I am unable to use the keyboard to enter text in any window, however the mouse functions correctly.

Well, hope anyone can help me get out of this mess :slight_smile:

I already figured out part of the problem…

My Yast automatically reinstalled the xorg and ati repository fglrx drivers, and this caused a conflict with the latest ATI fglrx that I rpm-ed.

Fixed that problem.

But now I am back at the original problem: no way to get my monitor above 60.0 Hz in ANY resolution.

xrandr keeps reporting 60Hz modes only, and so is sax2.

Good, you found the log but what did it tell you in (II) messages, about the default modes detected on probing (module “ddc”) your monitor?

It should be using that information to select the correct modes. After the probing shown in the log, you should see a lot of modes being rejected if they are outside the vertical or horizontal refresh rates specified in the xorg.conf file (they should match your monitor specs).

I can’t help with the ATI driver specifics, but others may do so. :slight_smile: