Wrong keyboard layout on most applications after fresh install

@gendjaral I have no idea. Setting QT_QPA_PLATFORM=wayland should invoke the QT wayland compatibility plugin. I can confirm that VLC missbehaves (“wrong keyboard”), I am not using any other SW off your list.

I can report more wayland weirdness here. I have a laptop which has a minimal installation, very clean in terms of installed SW, with the main purpose of running OpenFOAM, and openscad. I use https://github.com/OpenFOAM/OpenFOAM-dev when compiling under Wayland libvtknetcdf*.so.1 misses a function vtknetcdf_strlcat and compilation fails. If I compile the same under X11, it compiles and it also works under wayland.

So there seem to be subtle differences in 15.6 vs 15.5 which extend beyond “simple” runtime configuration.

Did you check that it actually runs as native Wayland application?

I also seem to have the same problem. Adding

setxkbmap -layout de

to my .bashrc helps.

Just confirming this discussion:
Me having on same PC (Leap 15.6 - Gnome) in two rooms different keyboards, one German and one English. Toggle the keyboard layout in Gnome works and e.g. gedit and LibreOffice react all fine. But e.g. YaSt and Trilium (Flatpak) completely ignore any German layout and stay English. Such makes work at my desk become highly annoying.

I tried both options mentioned here.
“setxkbmap -layout de” added to .bashrc => no change of behaviour
“export QT_QPA_PLATFORM=wayland” added to .bashrc => YaST does not launch anymore

As gendjaral already asked before: Has this bug already been reported?

I could solve using Yast - Hardware - Keyboard (Tastatur in German) and re-select the selected layout - German.
Without actively changing to something else and back to German the config was not re-written with setting German which looked correct in YaST

I have not yet created an issue in Bugzilla yet but will next. It would be nice of people with this issue can report back, if this solves their issues as well.

Could provide out of of "setxkbmap -print` before and after ? I forgot it and it might be helpful for the bug report. I anticipate some tool or script is not writing the keyboard layout correctly for all uses cases.

Please note if you are using Gnome/KDE/xfce/… and if you use wayland, xwayland …

Sorry for my late feedback.

@BierPizzaChips
Adding setxkbmap -layout de to ~./bashrc shouldn’t help as long you’re not starting the terminal. That is because ~./bashrc will only sourced by non-login shells in general. I’ve seen that @wolpers saying it is working, but installations are very different. Maybe he refers to the .bashrc elsewhere in a script and I didn’t want to get lost in details at this point.
What are you looking for should be .profile. But to be honest that didn’t work on my system too.
Anyway, that’s another detail topic in my opinion.

Regarding to the ‘keyboard layout issue’. There are some issues open to this and a fix is already existent (in the pipeline) but unfortunately still not released in the main repositories:

Two options:

Fixed source is here:

Too quick - it does not survive a reboot :frowning:

It is covered in following bug which is fix and an update is is the queue:
https://bugzilla.suse.com/show_bug.cgi?id=1219505#c82

Use the work around suggested by gendiaral or use RPM suggested in the bug if you cannot wait.

Almost forgotten:
Using Gnome/KDE temp. under Xorg instead of the default Wayland session will also prevent this problem.

I had some issues with a wrong keyboard layout in some Steam games and for me, changing /etc/environment did the trick:

XKB_DEFAULT_MODEL=pc104
XKB_DEFAULT_LAYOUT=de

Maybe it helps someone.

Wow! Fix!!! :partying_face:
One of today’s updates has fixed this issue for me.
Fantastic!!! Many thanks to then Suse team and their helping hands. :heart_eyes:

1 Like

Beyond setting QT_QPA_PLATFORM no. How can I check?

xlsclients