Wrong digest

I’m trying to make a new install of 13.2 tumbleweed. During the installation I get the following error;

Wrong digest
The expected checksum of file /mnt/var/cache/zypp/packages/openSUSE-20141208/suse/noarch/kernel-firmware-20141122git-1.1.noarch.rpm is [checksum], but the current checksum is [checksum].

(The [checksum] is an actual checksum I just don’t feel like typing it out)

So what can I do now? Is it safe? Doesn’t sound safe… :wink:

No, this is definitely not safe.
Although if only the kernel-firmware package is affected, you might not have any problems if you’re lucky (depending on what’s exactly wrong with the package and what hardware you have).

How exactly are you trying to install Tumbleweed?
This could happen if the DVD is bad e.g. Have you done a media check?

I wrote the openSUSE-Tumbleweed-DVD-x86_64-Current.iso to an USB drive with dd. I’ve done that before on my desktop but now I want to install on my laptop too and had to download the iso again.

Could you please explain how I can do a ‘media check’?

Although wolfi323 is a person with much knowledge, also about Tumbleweed, you would have done better to start this thread in the Tumbleweed, Evergreen, Pre-release forum. That is were Tumbleweed users gather to help other Tumbleweed users and to look for solution on Tubleweed problems.

Sorry, I didn’t know there was a dedicated forum for it. I’m new here.

Ok, when using an USB drive, there shouldn’t go anything wrong while copying. Such things happen more likely when burning a CD/DVD…

But the download might have been corrupted somehow in the first place. And as the image is larger than 4GiB, it will get corrupted if you copy it to a FAT partitition (FAT has a maximum filesize of 4GiB).

Could you please explain how I can do a ‘media check’?

There should be an option in the boot menu IIRC.

Personally I always prefer to use the NETinstall-CD, if possible. The chance that something gets corrupted there is minimal, as most things (even the installer itself) are downloaded from the Internet during installation. And you only have to download the stuff that you actually install… :wink:

Your actual question isn’t really related to Tumbleweed at all, I’d say.

But there might be general problems with that Tumbleweed DVD at the moment e.g.
People in the Tumbleweed forum would more likely to know that if that’s the case.

I tried that route instead and it worked like a charm. Thanks a lot for the help! Now I’m fully migrated to Suse.