"wrong digest message"&"installation package failed"messages causes suse12.1x64 installation lame

Hi,
Trying New Installation for opensuse 12.1 x86_64, I am getting these 2 errors many times:

  1. Wrong Digest: The check-sum must be x but it is y!!! it means that the file has been changed or being hacked (sth like this).
    If I choose yes the installation will stop with error!!! if I choose no the installation will continue with more errors like this and also below error.

  2. Installation package at failed. If I choose abort the installation will be aborted and if I choose ignore, the installation will continue with more errors of this kind and also the above error.

finally the inintrd could not be created and the installation is finalized with nothing installed. The Grub will not boot and the system remains corrupted.

Note: I downloaded the DVD compilation from the corresponding page on opensuse.org. The download progress lasted more than 7 days{due to connection speed and file size}
Note: I have Win 7 x64 installed.

Any one could help me please?
I don’t want to install Ubuntu, Unless having no hope for opensuse

Hi, a warm welcome here.

Thanks for the accurate information, this can lead to only one conclusion, which you can verify: the download, or the burnt DVD, is corrupted. To verify, perform the media check from the installer, it will no doubt tell you the DVD is not OK. This will result in equally corrupted packages, i.e. damaged software.
A solution: download a LiveCD of the desktop of your choice, preferably by bittorrent, since that allows you to check the downloaded chuncks and redownload missing or damaged parts. If you downloaded the DVD that way, check the torrent download, restart it to complete it to a 100% OK.

On 2012-05-19 12:36, ehsanmahdavi wrote:

> Any one could help me please?

There is a high chance that your DVD was corrupted on download, or when you
burnt it.

Go to the Download
Help
page. First have a look at the “Checksums” section, and do it.
If the iso image is bad, as we suspect, correct it, do not download it
again. The next section in the page is “Repairing a download”.

If you have not access to rsync (I don’t know how to use it in Windows⁽¹⁾),
the next bet is download using
metalinks (pity there is
no aria2c for windows). Else, use a good torrent downloader. The trick
here to correct a download is to start the download new, stop it after a
few minutes, substitute the partially downloaded file with the bad file you
got (complete but bad download), and restart/continue the download. The
downloader should then check the downloaded file, compare it with the
metalink or torrent data for corrupted chunks, and re-download again only
the corrupted sections.

When it finishes, you should have a correct iso file, which you should then
burn with verification active.

(1) rsync


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi, and thanks 4 ur quick response
Yes… “checksum wrong
this DVD is broken”!!! the media check says.
I suspected about the DVD, but I don’t know how I was sure that the media check will not recognize it. For the 1st time I used it… and it worked!
After all… am gonna download the DVD again!!!
I will download it from here directly. (I’ll use the Internet Download Manager in my win 7) hope this time won’t be corrupted.

A LiveCD downloads quicker + you can easily create a bootable USB device from it.

Dear carlos, Hi
1stly I would like to appreciate your resposne
I checked the .iso file by running it in VMWare workstation(in windows).
It was corrupted.
I wanted to download it again by direct downloading it as I mentioned in the last post.
But as you recommend and it’s tempting, I want to correct it. But your link for “Download
Help page” is also broken!!!
again thanks

The reason I chose the OpenSuse is that I want the whole package!!!
better sayin one of the reasons!!!
And may be it’s because am not a professional using linux!!

On 2012-05-19 14:36, ehsanmahdavi wrote:
> But as you recommend and it’s tempting, I want to correct it. But your
> link for “Download
> Help page” is also broken!!!

No, it is not. I clicked on it in the forum and it worked.

Here you have it via another method:


http://en.opensuse.org/SDB:Download_help


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-05-19 14:46, ehsanmahdavi wrote:
> The reason I chose the OpenSuse is that I want the whole package!!!

No need to shout.

You get the whole thing no matter what installation method you choose. If
you install via CD, you simply have to download the rest later. Besides, if
you install via DVD, you will have to update a lot of things via internet
(my local update copy has more than half a gigabyte (3 GB for 11.4)).

The advantage of using the DVD is that you have a choice of desktops, fine
tuning the packages you want installed, less memory foot print during
installation, and that you can also run upgrades.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Am sorry if my keystrokes looked like I was shoutin…
thanks again