Wrong Digest - can't add repository or update


Since yesterday (at least that’s when I noticed) either updating or adding repository is not working. When I run online update, it gives warning “Wrong Digest” and also gives following warning.

There was an error in the repository initialization.
‘openSUSE-11.1-Updates’: |] Failed to cache repo (4).

  • ‘repo2solv.sh’ ‘-o’ ‘/var/cache/zypp/solv/openSUSE-11.1-Updates/solv’ ‘/var/cache/zypp/raw/openSUSE-11.1-Updates’

gzip: primary.xml.gz: not in gzip format

gzip: susedata.xml.gz: not in gzip format

gzip: updateinfo.xml.gz: not in gzip format
repo_updateinfoxml: no element found at line 1:0

Thanks in advance.


Try this first:
Open a terminal and go su and do:

rpmdb --rebuilddb

It may help. Come back if it doesn’t.


I removed all repositories in yast2 and did “rpmdb --rebuilddb”.
Then I added the 11.1 oss repo by issuing following command.
“zypper addrepo Index of /distribution/11.1/repo/oss oss”

Then when I try to refresh by “zypper ref”
I get the following wrong digest error
“Digest verification failed for dvd-11.1-71.1.i586.pat.gz. Expected 1e69c0fe3c858c38e01668372207c21cd8a7daa5, found 4a59fcad0e70adfe7eeb4e2b968b7bad3280755d. Continue? [yes/NO]:”

I get same error for any repo I try to add.

Thanks in advance.


Let’s clear the repo’s and add them in this way. Here are some guides
Repository Management - openSUSE Forums

carl4926 - Adding Repo in Yast

add in these URL’s

Index of /distribution/11.1/repo/oss

Index of /distribution/11.1/repo/non-oss

Index of /update/11.1

I found the problem.
I had enabled the systemwide proxy using squid and dansguardian. That must have caused some sort of conflict. Disabling the system proxy fixed the issue.

Thanks for your help.