Wrong description in YaST for NVIDIA drivers

Hi all,

Perhaps I am being stupid here, please could somebody help.


So I wanted to install NVIDIA driver. I added the repository and looked through the available packages in YaST. I noticed that the “G06” (driver version 510) is the one recommended for 700 series and newer cards. So I decided to tick the box and click “accept”. Install worked, rebooted PC, ended up with 640x480 resolution or similar (I don’t remember exactly). Spent a long time trying to figure out what I had done wrong. Eventually decided to try “the hard way” so I went to NVIDIA site and followed the instructions and all worked fine. But then Steam didn’t work at all, it would crash on launch with “swrast” error. I searched the internet and decided this must be to do with graphics drivers and that it was probably because I used “the hard way” which is not recommended by NVIDIA. So I looked in YaST again and then noticed that the G06 driver which YaST recommends for my 700 series card is version 510, but on the NVIDIA website it says that the newest version supported by my card is 470. I installed “G05” (version 470) through YaST and Steam and everything else is perfect now. I then downloaded 510 from NVIDIA and tried to install that version “the hard way” in order to check that it really is not compatible, and it immediately warned me that it would not work with my card.

Please could somebody explain why YaST recommends nvidia driver 510 (“G06”) for 700 series cards when it does not actually work with these cards at all?


It probably has something to do with QA being unable and/or unwilling to test all zillion NVidia models with all versions of NVidia’s proprietary drivers, and/or the openSUSE community being an imperfect translator of NVidia instructions to data YaST can use. YaST is probably forced to use a guessing paradigm to suggest which to use.

If the FOSS drivers can’t support audio on the realtime kernel, that’s a bug, which you could help to get fixed by reporting it, so that developers know the problem exists.

Thanks for your reply. Who would I contact to let them know that they have written the package descriptions incorrectly for the proprietary drivers?


Username and Password as here in the Forum.