Wrong clock in 11.0

In installation process I chose correct my region and timezone. Installer show me correct time. After install I entered in system and got correct time again. But then I rebooted I got wrong time about 4 hours forward.

‘date’ show me wrong time, but ‘hwclock --show’ show me correct time. Also if I do ‘/etc/init.d/boot.clock restart’ time goes to correct value. But after rebooting I have it problem again.

I tried some methods, like delete /etc/adjtime etc, but it’s doesn’t work.

In 10.3 I have no any problems with clock.

open with your favorite editor /etc/sysconfig/clock find the line SYSTOHC=“yes” and change it to no. That way it does not write back the system time to the hardware clock at reboot or shutdown

You have probably set time to UTC and need to set it to local clock?

geologos, yeah I did that already, because system changed hwclock in cmos. But this didn’t solve problem with system time.

Magic31, local clock. In /etc/sysconfig/clock I have HWCLOCK="–localtime".

I do not think this is a good idea. It is the normal way to go, either setting the clock on shutdown to local time or to zero time (the former only if you crossboot to an OS that does not know about zero time).
In any case this setting of the hwclock can not make your system be off for four hours.

Having said this I do not know what the real reason is (I have still 10.3 and happy with it). Check if your NTP server is OK. Check your time zone setting in YaST and try again.

BTW if you crossboot with an MS system, did not set ‘setting your HW clock to local time on shutdown’ and corrected your time being in the other OS and there is four hours between local time and zero time (a long IF … AND … AND …) then I do understand, but that would go wrong in 10.3 also.

If we do “/etc/init.d/boot.clock restart”, we have correct time. Why we havnt correct time after boot?

I add in boot.clock as first unncoment line this: ‘echo “hello” >> /tmp/my.log’ and check after reboot file my.log. Nothing. It dont execute in boot time.

Then I add boot.clock script at 5 level run as “sudo ln -s /etc/init.d/boot.clock /etc/init.d/rc5.d/S99boot.clock” and rebooting. I got correct time and record in my.log. It’s work.

Then now question is why boot.clock dooesnt execute in S level in boot time?

Is there a symbolic link for boot.clock (and getclock) in /etc/init.d/boot.d?

You could try ’ insserv boot.clock ’ as root to see if some link was not in place?

S04boot.clock → …/boot.clock
S12boot.getclock → …/boot.getclock

insserv boot.clock - nothing.

I had a dig in bugzilla, this one could be interesting?

See comment nr 5.

This one could also be relevant : https://bugzilla.novell.com/show_bug.cgi?id=384254

These should all be fixed though… ? Curious, what did you use to install openSUSE with?


Nothing work :\

I installed from iso image (openSUSE-11.0-DVD-i386.iso) booting with mini boot cd (openSUSE-11.0-NET-i386.iso). This method have also problem with language in installation time if it isnt english. But it solved yet in another thread.

Sorry to hear that… :confused:

I had some issues with my clock going forward when running the Beta’s…
This was solved when I reinstalled using the final release media.

I’m not sure we can help as you’ve seem to set everything correctly…

It could be an option to add your comments to the existing bug report and see if any suggestions come back from that?

But I solved problem for me. I think it’s not fully correct, but it work.

  1. Check hardware clock
sudo /sbin/hwclock --show

and correct it if not.

sudo ln -s /etc/init.d/boot.clock /etc/init.d/rc5.d/S99boot.clock
  1. Reboot.

I though you wanted it to work the ‘official’ way and get why it was not working in the first place. Hence my suggestion…

Party on then :wink:

I was having the same problem with my install of Suse 11.0_64. I went to Yast and selected System and the Date and Time. I set the date and time using a selected NTP and then configured it to run at boot time. That seemed to work just fine. I have rebooted 10 times and it has had the right clock time every time now. Hope this works for you:D:D

This is the way to go

I am having a slightly different problem. The time on the clock display is correct and files are saved with the correct times when displayed with “ls -l”. YaST also shows the corect time and timezone. But when listed in Dolphin the times are advanced 7 hours. Annoying to say the least. Running 11.0 fully updated.

This could be KDE 4.0 specific, buggy bug bug?.. do you get the same browsing with Konqueror?

Konqueror shows the same incorrect time as Dolphin. This is definitely some kind of KDE4 bug. I have no idea what could cause the Konqueror and Dolphin listings to display a different time from the Konsole, especially when the Konsole time was the same as the KDE digital clock time when the file was created.

Dolphin and kong here displays the correct time. Have you tried setting the date and time using a selected NTP in yast?

For bawolk the issue is different… If the shifted time stamp was only for newly created files that would be a place to look… but all files are being shown with a consistent +7 hours time stamp.

@bawolk, opening a console and switching to root, do you get the exact same time when looking at:

hwclock --show

Other than that there could be some user setting where you also have to set the timezone in KDE…? Not a heavy KDE user myself so wouldn’t know if there is… but have another browse through all settings?