writing mbr to first disk

A couple of weeks ago I installed OpenSuse Leap 42.3 but it installed to sdc instead of sda. I wanted to add it to my grub2 bootmenu which had the mbr on sda. I tried installing it twice more but still missed the place in the installation wizard where I could specify to write the mbr to sdc. I now have Tumbleweed Live DVD installed to a DVD but as soon as I booted to the startup screen i recalled that this was like the OS that kept writing the boot menu to the third drive instead of the first. Would you be kind enough to tell me if there is a way to tell OpenSuse Tumbleweed to write the MBR and/or boot loader to sda I am hoping to then use Grub Customizer to be able to add OpenSuse Tumbleweed it to my esisting Grub2 boot loader. Thank you very much fpr your kind consideration.

Don’t think you can write MBR to a different drive unless you have at least a /boot partition on that drive.

MBR does not have the power to cross drives.

Also are you sure you boot installer in legacy mode and not EFI mode???

If you plan to have an OS that lives on sda control the boot it should still be able to chain to the sdc drive. Or you could make sdc the boot drive and chain to other OS from the openSUSE grub on sdc

@gogalthorp - I think you can write an ‘mbr’ to each disk, and then choose boot device via bios.

I’m just saying that after the installation was finished, I had to go into my BIOS settings so that the first disk in hard drive order was the third disk instead of the first otherwise I just entered the original Grub 2 customized boot loader that i had all along. When I booted into the third drive I got the OpenSuse bootloader with OpenSuse listed first but I had no way to customize it or add the OpenSuse to the first bootloader. I remember looking in the installer and seeing the three drives listed in a little window as sdc/sdb/sda only vertically. The second time I did the installation I reversed this little list to sda/sdb/sdc/ but it made no difference to the result. FYI all my Linux Distros are on sdc. There are Windows only on sda and on sdb. I’ve never heard about EFI until I started reading these forum threads a few weeks ago. I have an Asus P5B-VM with an Intel Core 2 Quad Q6900. I’m guessing I installed the motherboard around 8 years ago. AFAIK UEFI was unheard of back then. I tried Chain loading wihin Grub Customizer by Daniel Richter but it did not work. i also tried to use Yast inside OpenSuse to move the bootloader to SDA/ but that did not work either.

The other thing I should mention is the fact that GParted reports “can’t have overlapping partitions.” for SDA and SDB and FDisk reports disks in wrong order for SDB. When I looked at SDB in GParted this morning it said unallocated space for the whole drive, but when I used Gparted from another distro in a higher numbered partition the same drive looked as usual.

Intuition tells me I should be trying to fix the partitioning issues first but all the OS’s are booting fine at this moment. It’s not really broke as far as booting is concerned. Only some new installations are giving me trouble, although a Ubuntu installation to SDC/20 a few days ago completed without a hitch

Thanks again. I could always install Tumbleweed knowing that i’m going to have to go to BIOS to access it.

Arch Parsons

Looking at Yast bootloader, there’s a box toward the bottom left “Edit Disk Boot Order”. You should set the order so that the disk you want for boot disk is first.

You can also change the order by moving the control wires in back of the drive. Or change boot order in the BIOS once in Linux you should be able to chain to Windows from grub but you may need to set scan for foreign OS in Yast-Boot loader if Windows does not show from the Grub2 menu. Or you can edit the grub config files. Windows without a boot loader program will not chain to Linux but Linux does chain to Windows so Linux must be the control of booting

Different question.

The OP was not wanting to change the boot order.

Given the actual boot order, the OP wanted grub2 to be installed appropriately for that boot order.

The “Edit Disk Boot Order” is not intended to change the boot order. It is intended to make sure that the boot loader is installed appropriately for the actual boot order.

Usually, the installer gets it right. But sometime it needs adjusting.

True but grub has to run for it to work and MBR won’t go to a different disk (yes it does work with EFI but not MBR). Thus BIOS would need to be changed or a boot partition set on the boot disk or physical order changed. But with MBR something is needed on the boot disk to chain to grub some how.

Nonsense. “Installing GRUB in MBR” means writing core.img to post-MBR gap. It can be done onto any disk.

On summary screen click bootloader, you then can uncheck all locations (root, /boot etc) and enter specific device in custom bootloader location field (you can even add several devices there for redundancy). Also uncheck “install generic bootloader”.

Well with Windows in the mix it normally needs to be generic code in the MBR and that is tied to the Disk. Because Windows tends to like to overwrite the MBR on updates.

I may be misunderstanding your problem but why not install tumbleweed with no bootloader and add the appropriate /boot details to your original grub.cfg with 40_custom or 90_persistent?
That way you keep the original bootloader on sda.