WPA2-PSK [AES] with Network Manager

I am trying to set up a wireless network with the Network Manager. The encryption is WPA2-PSK [AES]. This works fine from Yast using the traditional ifup method but I cannot see that option in Network Manager. Is there a way to add this option there? It would be easier tom manage all connections from the desktop applet.

Normally you shouldn’t have to set the encryption manually, as NetworkManager should be able to figure this out by itself.

So, have you tried to just set up the connection?

I do see “WPA/WPA2 Personal” in there. Does this not work? (PSK is implied by “Personal”, and AES is the standard encryption method for WPA2, AFAIK)

I’m not sure where you are looking. The option is certainly there. It’s what I use on my home network.

If you need pointers on exactly where to look, then you need to tell us:

  • what version of opensuse you are using;
  • which desktop (Gnome, KDE, etc) you are using.

I am running 13.1 with KDE 4 that I just installed on a new Dell laptop. I tried “WPA/WPA2 Personal” first but that would not connect. I then connected from Yast like I normally would on a desktop. In Yast I can sellect WPA2-PSK option, add the password and all just works. I will be doing some traveling with this laptop though and I would prefer to have a desktop applet.

On 06/13/2014 08:06 AM, gosvald wrote:
>
> I am running 13.1 with KDE 4 that I just installed on a new Dell laptop.
> I tried “WPA/WPA2 Personal” first but that would not connect. I then
> connected from Yast like I normally would on a desktop. In Yast I can
> sellect WPA2-PSK option, add the password and all just works. I will be
> doing some traveling with this laptop though and I would prefer to have
> a desktop applet.

It should work from NetworkManager. On some earlier versions of openSUSE, one
had to enter the connection details from the Connection Manager screen of the
applet. In general, that has not been necessary with 13.1, but you might try it
anyway.

The applet is in the system tray, not on the desktop. I’m sure that is what you
meant, but I point that out for completeness.

Again, you should not have to select anything. You should not have to configure anything actually. Just connect to your access point and type in the password when asked.
“WPA/WPA2 Personal” should be the same as WPA2-PSK though.
And it works fine here as well.

Maybe you made a typo in the password? Or connected to the wrong AP?

Try to run NetworkManager in a terminal window and post the debug output when connecting:

sudo systemctl stop NetworkManager
sudo /usr/sbin/NetworkManager --no-daemon --log-level=DEBUG

Ok Guys. Somehow it started working. Previously I always entered all settings manually in “Manage Connections”. What I tried this time was entering the SSID to <hidden network> text field in the applett (I am not broadcasting SSID). I entered exactly the same details as several times before and it just started working. Thank you for your help.

NetworkManager has always been a bit finicky with hidden networks. But, once you get it working the first time, it should continue to work without problems.

On 06/13/2014 08:56 AM, gosvald wrote:
>
> Ok Guys. Somehow it started working. Previously I always entered all
> settings manually in “Manage Connections”. What I tried this time was
> entering the SSID to <hidden network> text field in the applett (I am
> not broadcasting SSID). I entered exactly the same details as several
> times before and it just started working. Thank you for your help.

Please specify that you are using a hidden SSID when reporting problems. That
changes a lot of things.

BTW, hiding your SSID may cause other problems. It adds almost nothing to your
security as the AP can be found by an experienced user with very little effort,
and it could add to interference because another AP in the neighborhood may
select your channel as a cursory scan will not see it.