WPA not working anymore with ath5k / NetworkManager (NC10)

Hello,

for any reason my wifi isn’t working with WPA anymore.

System is openSUSE 11.1 on a Samsung NC10 with Atheros AR242x wifi card.

> /sbin/lspci
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

> /sbin/lspci -n
02:00.0 0200: 168c:001c (rev 01)

It all works with windows and did work with Linux. But for some reason if I try to connect to an encrypted network now it fails with following messages:

> tail -f /var/log/NetworkManager
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) starting connection ‘TKLS’
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): device state change: 3 → 4
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled…
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started…
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled…
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting…
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): device state change: 4 → 5
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0/wireless): access point ‘TKLS’ has security, but secrets are required.
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): device state change: 5 → 6
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Feb 27 09:04:20 Annie NetworkManager: <WARN> get_secrets_cb(): Couldn’t get connection secrets: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface “org.freedesktop.NetworkManagerSettings.Connection.Secrets” member “GetSecrets” error name “(unset)” destination “org.freedesktop.NetworkManagerUserSettings”).
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): device state change: 6 → 9
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) failed for access point (TKLS)
Feb 27 09:04:20 Annie NetworkManager: <info> Marking connection ‘TKLS’ invalid.
Feb 27 09:04:20 Annie NetworkManager: <info> Activation (wlan0) failed.
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): device state change: 9 → 3
Feb 27 09:04:20 Annie NetworkManager: <info> (wlan0): deactivating device (reason: 0).

> tail -f /var/log/messages
Feb 27 09:04:20 Annie kernel: wlan0: authenticate with AP 00:18:84:18:a1:b5
Feb 27 09:04:20 Annie kernel: wlan0: authenticated
Feb 27 09:04:20 Annie kernel: wlan0: associate with AP 00:18:84:18:a1:b5
Feb 27 09:04:20 Annie kernel: wlan0: RX AssocResp from 00:18:84:18:a1:b5 (capab=0x421 status=0 aid=1)
Feb 27 09:04:20 Annie kernel: wlan0: associated
Feb 27 09:04:20 Annie kernel: wlan0: disassociating by local choice (reason=3)

I tried to delete the AP in NetworkManager and reconfigure it but that didn’t help. My NC10 has the newest firmware installed. Connecting to an open spot works.

Any ideas?
Kai

kwbolte wrote:
> for any reason my wifi isn’t working with WPA anymore.

What did you do between the last time it worked and now?

I was afraid of that question :wink: .
I think I plugged of the power cord while online by accident (battery not installed) so the netbook switched off. But I can’t imagine that this crashed wpa_supplicant or something.
I’ve done a BIOS-update, too. But I think afterwards it worked first.

Really nobody an idea?
WEP isn’t working, too. It is only connecting to open access points, so it seems to be something with wpa_supplicant and NetworkManager? How can I reset all settings to default?
No surprise: If I configure it with ifup everything works, so it’s - again - an issue with NetworkManager. :frowning:

kwbolte wrote:
> Really nobody an idea?
> WEP isn’t working, too. It is only connecting to open access points, so
> it seems to be something with wpa_supplicant and NetworkManager? How can
> I reset all settings to default?
> No surprise: If I configure it with ifup everything works, so it’s -
> again - an issue with NetworkManager. :frowning:

Are you using KDE4? NetworkManager with WEP, or WPA works just fine with KDE3.

Yes, I’m using KNetworkManager from KDE3 within KDE4, so that shouldn’t be the problem. And it all worked before.

kwbolte wrote:
> lwfinger;1954014 Wrote:
>> Are you using KDE4? NetworkManager with WEP, or WPA works just fine
>> with KDE3.
> Yes, I’m using KNetworkManager from KDE3 within KDE4, so that shouldn’t
> be the problem. And it all worked before.

Does the NetworkManager log show anything?

Well, the log is in my first post above, do you need something different?

I had the same issue, but my wireless card is a BCM43, just downgrade the NetworkManager to a previous version

I also have the same problem with my Atheros card, see below. These problems occured after the latest NetworkManager update (problems with it are discussed in another thread). When I regress to the old NetworkManager (from the install DVD) my WiFi works again. Any thoughts on fixing this issue with the latest NetworkManager?

Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) starting connection ‘Auto Chica’
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): device state change: 3 → 4
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) scheduled…
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) started…
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) scheduled…
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 1 of 5 (Device Prepare) complete.
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) starting…
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): device state change: 4 → 5
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0/wireless): access point ‘Auto Chica’ has security, but secrets are required.
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): device state change: 5 → 6
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) Stage 2 of 5 (Device Configure) complete.
Mar 19 22:25:43 lnxlptp NetworkManager: <WARN> get_secrets_cb(): Couldn’t get connection secrets: Rejected send message, 11 matched rules; type=“method_call”, sender=":1.8" (uid=0 pid=3431 comm="/usr/sbin/NetworkManager “) interface=“org.freedesktop.NetworkManagerSettings.Connection.Secrets” member=“GetSecrets” error name=”(unset)" requested_reply=0 destination=“org.freedesktop.NetworkManagerUserSettings” (uid=1000 pid=4436 comm="nm-applet --sm-disable ")).
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): device state change: 6 → 9
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) failed for access point (Chica)
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Marking connection ‘Auto Chica’ invalid.
Mar 19 22:25:43 lnxlptp NetworkManager: <info> Activation (ath0) failed.
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): device state change: 9 → 3
Mar 19 22:25:43 lnxlptp NetworkManager: <info> (ath0): deactivating device (reason: 0).

-jmj75

Latest NetworkManager Broken - openSUSE Forums

jmj75 wrote:
> Mar 19 22:25:43 lnxlptp NetworkManager: <WARN> get_secrets_cb():
> Couldn’t get connection secrets: Rejected send message, 11 matched
> rules; type=“method_call”, sender=":1.8" (uid=0 pid=3431
> comm="/usr/sbin/NetworkManager “)
> interface=“org.freedesktop.NetworkManagerSettings.Connection.Secrets”
> member=“GetSecrets” error name=”(unset)" requested_reply=0
> destination=“org.freedesktop.NetworkManagerUserSettings” (uid=1000
> pid=4436 comm="nm-applet --sm-disable ")).

This problem has a work-around as follows:

Line 13 of /etc/dbus-1/system.d/nm-applet.conf will contain a line that has

<deny send_destination=“org.freedesktop.NetworkManagerUserSettings”

The indenting is different so it won’t look exactly the same. Edit it and change
“deny” to “allow”. Your WPA will work again.

Be aware that this “fix” has a downside. After you do it, any user can see the
WPA secrets. For me, having NM control the wireless is more important.

Larry