WoW and ATI graphic/text problems

Hello, I am quite new to linux, but after some time now I would like to switch to fully to a linux desktop, also to play Warcraft. This was the last years the only big barrier. Now I took some time and configured my little machine and tried to get Wow to run.

The Problem: is that i can start Wow successfully and everything works best until I choose my character and enter the game. At first everything seams ok but after 2-3 seconds I only can see the first letter and after that nothing. I cant read charnames, quests, nothing…
The second problem are the graphic ingame, simultanously with the textproblem flickering lines occour.

Linux i686
openSUSE 11.0 (i586)
KDE: 4.0.4 (KDE 4.0.4 >= 20080505) “release 15.1”

Graphic Card:
ATI Technologies Inc
Radeon X1900 Series (R580 7249)

Prozessor (CPU): Intel(R) Core™2 CPU 6600 @ 2.40GHz

I installed the fglrx driver for the ATI Card from the ATI Repository.

After having a working 3D acceleration I tried to get WoW working.
I installed Wine also via the repositories (Wine 1.0 rc3).
I modified the Registry for OpenGL:
HKEY_CURRENT_USER\Software\Wine\OpenGL=GL_ARB_vertex_buffer_object (like it is described here Linux/Wine - WoWWiki - Your guide to the World of Warcraft).
And also modified the config file of WoW in the WTF folder:
SET locale “deDE”
SET coresDetected “2”
SET hwDetect “0”
SET gxColorBits “24”
SET gxDepthBits “24”
SET gxResolution “1280x1024”
SET gxRefresh “60”
SET gxMultisampleQuality “0.000000”
SET gxFixLag “0”
SET gxWindow “1”
SET videoOptionsVersion “1”
SET movie “0”
SET expansionMovie “0”
SET readTOS “1”
SET readEULA “1”
SET readTerminationWithoutNotice “1”
SET readScanning “1”
SET showToolsUI “1”
SET Sound_OutputDriverName “System Default”
SET realmList “
SET patchlist “
SET SmallCull “0.040000”
SET DistCull “500.000000”
SET farclip “500.000000”
SET specular “1”
SET particleDensity “1.000000”
SET groundEffectDensity “24”
SET Sound_VoiceChatInputDriverName “System Default”
SET Sound_VoiceChatOutputDriverName “System Default”
SET realmName “Baelgun”
SET cameraPitchMoveSpeed “90”
SET cameraPitchSmoothSpeed “45”
SET gameTip “9”
SET ffxDeath “0”
SET ffxGlow “0”
SET UIFaster “2”
SET M2UseShaders “0”
SET gxApi “opengl”

at last here is the last part of my xorg.conf:
Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 376 301
HorizSync 30-83
Identifier “Monitor[0]”
ModelName “BENQ FP93GX”
Option “DPMS”
Option “PreferredMode” “1280x1024”
VendorName “BNQ”
VertRefresh 43-76
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x1024” 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “Radeon X1900 Series (R580 7249)”
Driver “fglrx”
Identifier “Device[0]”
Option “SaXDualHead”
Option “XAANoOffscreenPixmaps” “true”
Option “Capabilities” “0x00000800”
Option “UseFastTLS” “off”
Option “KernelModuleParm” “locked-userpages=0”
Option “SaXDualMode” “Xinerama”
Option “ForceMonitors” “auto,crt1”
Option “SaXDualHSync” “30-83”
Option “SaXDualMonitorModel” “BENQ FP93GX”
Option “SaXDualVSync” “50-76”
Option “VRefresh2” “50-76”
Option “Mode2” “1280x1024,1280x960,1280x800,1152x864,1280x768,1280x720,1024x768,1280x600,1024x600,800x600,768x576,640x480”
Option “FSAAScale” “0”
Option “FSAAEnable” “off”
Option “VideoOverlay” “on”
Option “SaXDualMonitorVendor” “BNQ”
Option “HSync2” “30-83”
Option “DesktopSetup” “Horizontal”
Option “SaXDualResolution” “1280x1024”
Option “SaXDualOrientation” “LeftOf”
Screen 0
VendorName “ATI”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”
Option “Composite” “on”

I am opening the WoW.exe with: wine Wow.exe -opengl
messages while starting:
fixme:advapi:SetSecurityInfo stub
archive Data\patch.MPQ opened
archive Data\deDE\patch-deDE.MPQ opened
archive Data\deDE\patch-deDE-2.MPQ opened
archive Data\patch-2.MPQ opened
archive Data\expansion.MPQ opened
archive Data\common.MPQ opened
archive Data\deDE\locale-deDE.MPQ opened
archive Data\deDE\speech-deDE.MPQ opened
archive Data\deDE\expansion-locale-deDE.MPQ opened
archive Data\deDE\expansion-speech-deDE.MPQ opened
fixme:win:EnumDisplayDevicesW ((null),0,0x32eda4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32ec94,0x00000000), stub!
fixme:d3d:test_pbo_functionality >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from Loading the PBO test texture
@ directx.c / 3520
fixme:win:EnumDisplayDevicesW ((null),0,0x32f42c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a8,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f5a0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f57c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32f144,0x00000000), stub!
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONNECT_TIMEOUT (5000): STUB
fixme:reg:GetNativeSystemInfo (0x37402bc4) using GetSystemInfo()
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
Unable to read extra attributes: “Cache\Survey.mpq”
fixme:winsock:WSAIoctl unsupported WS_IOCTL cmd (9800000c)
fixme:win:EnumDisplayDevicesW ((null),0,0x32d194,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x32d200,0x00000000), stub!
fixme:imm:ImmAssociateContextEx (0x20024, (nil), 16): stub

NEED HELP :smiley:
Greetings Soronume

first of all is that really the latest wine in the repo? (1.1.0 is out)

i take it you did this:

  1. Find HKEY_CURRENT_USER\Software\Wine\
  2. Highlight the wine folder in the left hand pane by left clicking on it. The icon should change to an open folder.
  3. Click right on the wine folder and select [NEW] then [KEY].
  4. Replace the text “New Key #1” with OpenGL (CaSe Sensitive).
  5. Right click in the right hand pane and select [NEW] then [String Value].
  6. Replace “New Value #1” with “DisabledExtensions” (CaSe sensitive).
  7. Then double click anywhere on the line, a dialog box will open.
  8. In the value field type “GL_ARB_vertex_buffer_object” (without the quotes).

And maybe in the config:
SET gxApi “opengl”
SET ffxDeath “0”
SET ffxGlow “0”
SET M2UseShaders “0”

and as far as i know if you do all that then you dont need to run it with -opengl.
Also try disabling vertex shader support with winecfg

At the moment I am not at home, but going to search for a new version of wine and will try it without the opengl option.
The steps you described where taken, yes.
Will disable the vertex shadders when I am back home, and report results.

Forgot to mention I added 4 dlls in the wine system32 directory (msvcp60.dll, mfc42.dll, riched32.dll, riched20.dll) some of them already existed and added them to run native under wine.

Redid the modification in the xorg.conf:
Option “Capabilities” “0x00000800”
Option “UseFastTLS” “off”
Option “KernelModuleParm” “locked-userpages=0”

back to:
Option “Capabilities” “0x00000000”

because my videoplayer didnt worked anymore.

I also read that it could be because of running compiz, but I use kwin as windowmanager as far as I know. Is there also a problem?

Greets Soronume

took wine 1.1.0 and after that the daily wine snapshot → still same error
disabled shader → still same error
started with and without -opengl → still same error


still help needed
greets soronume