World of Warcraft+Wine and low FPS

I am getting poor fps on world of Warcraft. It works fine, install with wine was easy as usual. I added SET gxAPI “OpenGL” to the It has been awhile since I used Linux and I think there is more I can do and edit, I just forgot :’( I have had better FPS in some areas, like starter areas, etc. That is even real low now. I use to get around 50-65fps there and it won’t go any higher then 24-25. Now in heavy traffic/graphic areas, like Dalaran, it is down to the single digits, as low as 5 and there I usually get around 15-25 depending on how many people are there. All World of Warcraft video settings are the same as they where in Windows. So I know the card can do better then it currently is with Wine. It is something else I am missing.

Edit: I am not using Compiz, I unistalled it.

*I have an Nvidia 8400GS, it is set up fine and working without issues with various Linux based 3D games.

*I am running Suse 11.1 64bit on an AMD Duel Core, KDE 4.2.4 Release 2

*Memory is 4gb (Actually it is reading 3.9GB)

*Monitor is an LQ Flatron W1952TQ, 1440x900, 10000:1 ratio, 2ms response

*Am I forgetting anything?

Any thoughts, ideas or links that can help out? Also here is my if anyone wants to look it over and let me know if I missed something, or what I missed. (I X’ed out the personal information of course.)

SET readTOS "1"
SET readEULA "1"
SET readScanning "-1"
SET readContest "-1"
SET readTerminationWithoutNotice "-1"
SET installType "Retail"
SET locale "enUS"
SET movie "0"
SET showToolsUI "1"
SET realmList ""
SET patchlist ""
SET coresDetected "2"
SET hwDetect "0"
SET gxAPI "OpenGL"
SET gxWindow "1"
SET gxResolution "1440x900"
SET gxRefresh "50"
SET gxVSync "0"
SET gxMultisampleQuality "0.000000"
SET gxFixLag "0"
SET videoOptionsVersion "2"
SET accountName "XXX"
SET mouseSpeed "0.5"
SET Gamma "1.000000"
SET lastCharacterIndex "6"
SET accounttype "LK"
SET VoiceActivationSensitivity "0.39999997615814"
SET Sound_OutputDriverName "System Default"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "177"
SET specular "1"
SET groundEffectDensity "24"
SET projectedTextures "1"
SET realmName "XXX"
SET gameTip "2"

Well I double checked and I appear to be using 32bit Wine. I thought if it was 64 bit wine, running a 32 bit program, that would cause some of the fps issues.

I am finding various information on this but nothing that I can use or that would/or is working on this computer.

Well Still at it.

I tried turning off PowerMizer, sync to vblank (Video Texture Adaptor) and flipping. Nothing there. With all the video settings turned to the lowest or off in WoW I am still only getting 30fps in Elwynn Forest. That should be at least 50-60 or more with it all off.

Still feels like I a missing something that I did before, been so long wish I could remember.

I am putting Wine on hold for now, giving Cedega a try.

Well forget that. Cedega wants me to pay first to install WoW. Not doing that unless I can see if it works first. Maybe I will try CrossOver instead. But later, I am getting annoyed at this. Might just throw XP on my other computer just for WoW.

Did you tried to disable desktop effects on kde4.2.4?

Plamsa? No I didn’t. I can give that a try. I am taking a break from WoW for a couple of months so I have time to figure this out. I might look around for a game similar to WoW if they have any that works natively on Linux. Been with WoW for a few years, might be time for a change, (Unless by some small chance they decide to get a Linux Installer going, which I highly doubt.)

SET coresDetected "2"
SET hwDetect "0"
SET gxApi "OpenGL"
SET gxMultisampleQuality "0.000000"
SET videoOptionsVersion "2"
SET particleDensity "0.10000000149012"
SET unitDrawDist "300.000000"
SET textureFilteringMode "0"
SET DesktopGamma "1"
SET ffxGlow "0"
SET ffxDeath "0"
SET fullAlpha "1"
SET lodDist "100.000000"
SET SmallCull "0.070000"
SET weatherDensity "0"
SET Sound_EnableEmoteSounds "0"
SET lod "1"
SET ffx "0"
SET alphaLevel "0"
SET environmentDetail "1.5"
SET Sound_MasterVolume "0.5"
SET targetNearestDistance "80.000000"
SET CombatLogRangeParty "200"
SET CombatLogRangePartyPet "200"
SET CombatLogRangeFriendlyPlayers "200"
SET CombatLogRangeFriendlyPlayersPets "200"
SET CombatLogRangeHostilePlayers "200"
SET CombatLogRangeHostilePlayersPets "200"
SET CombatLogRangeCreature "200"
SET doodadAnim "0"
SET shadowLOD "0"
SET MaxLights "1"
SET mapShadows "0"
SET anisotropic "0"
SET Gamma "1.000000"
SET showGameTips "0"
SET farclip "617"
SET pixelShaders "1"
SET scriptMemory "131072"
SET M2Faster "0"
SET uiScale "0.79999995231628"
SET useUiScale "1"
SET gxFixLag "0"

This used to work for me, even with desktop effects on.
Try to disable combat log features in game,
there’s a full log profile enabled by default,
it can sometimes cause problems when there’s many players around.

I just copied your and replaced mine. Right off I saw a major difference. Then I had to switch it to 1440x900 and the frame rate dropped about 15-20. With a little fine tuning with the video settings Elwynn is now at 50 fps, which is better. It is not the exact same that it was before, but it will do and it is much better. I will play around some more with the video settings. I want to try and get it to 60 without loosing too much, if I can. I haven’t tried Dalaran yet, but I could have three of the latest and greatest graphic cards, SLI, and still lag there, lol.


Also two thing helped on top of this. I turned off the in game vertical sync and I am running WoW in IceWM which makes it run a little smoother.

Thanks everyone for the help working through this.

SET maxFPS “100” - This is the FPS cap
SET maxFPSBk “5” - This is the FPS cap while in background

You can change the numbers if you like but you should be using SET gxVSync “0” with these.

SET extShadowQuality “0” SET shadowLOD “0” and SET mapShadows “0” are recommended for cards that have problems with rendering shadows.

You can also check your nvidia-settings and setup antialiasing and filtering to application settings and move the slider under opengl settings to high performance.

Glad I could help, enjoy.

Thanks for that additional info. I made the changes, checked the game out and it is working great now. Seems like fps is better now then it was with Windows.

The real test will be in a raid, WG or SotA. But I doubt there will be an issue. Dalaran is getting better fps now then it was with Windows. Still lags a little but that goes with the city.