Workqueue lockup after freezing and forced shutdown


I’ve had a weird issue with my laptop freezing while charging for about a month, but just dealt with it as I didn’t have time to mess with it. Usually just putted it to sleep while charging, as that worked fine. Sometime I am not able to just stop working though, so plug and pray.
Today it froze again, I’ve resetted it with power button as usual, but it refuzes to boot. First were TPM errors, so I disabled that to at least boot. Not so fast. Got greeted with repeating error:

BUG: workqueue lockup - pool cpus=1 node=0 flags=0x0 nice=0 stuck for Xs! 
in-flight: 1016:request_firmware_work_func"

(taken while booting in recovery mode, made no difference)
Laptop model:
CPU: Intel Core i7-8565U
GPU: Intel UHD 620
SSD: SanDisk SD9SN8W5
Wi-Fi: Cannon Point-LP CNVi
Sound: Cannon Point-LP High Definition Audio Controller
USB: Cannon Point-LP USB 3.1 xHCI Controller
I guess it’s everything that could possibly need firmware?

Windows booted fine, but I can’t really use it for anything other than testing if it boots, unfortunately.
Soo that’s it. Where should I look?

Thanks in advance for any help.

Is Tumbleweed using kernel-5.10.1?

If it is, try booting an earlier kernel.

I ask, because “workqueue lockup” was the title of one of the bug reports about kernel-5.10.1.

LMAO, it actually worked. Didn’t even thought about that because it already booted 5.10.1 multiple times with exactly the same circumstances.
Thank you very much, that was pretty bad by me.