Working wireless connection but no internet

I’ve installed opensuse 11.2 on an old IBM thinkpad. The install went without a hitch and when I got to the desktop I inserted my Dlink DWL-G132 wireless USB adapter. Opensuse immediately recognised that a wireless device was attached and I could see my wireless network listed. I entered my WPA password and was able to connect to my routers configuration page by entering in the URL bar of firefox. For some reason I am unable to navigate to any webpage. When I enter a URL firefox acts as though there is no internet connection. The only way I can get the internet on my laptop is to connect it to my router with a cable. I used a wired connection and ran the update utility thinking that perhaps an update would fix the issue but it did not. I know the adapter works because the laptop used to have windows xp installed and I could connect fine with that.

Does anyone here have any idea why I would be able to connect wirelessly to the routers configuration page but not to the internet? I appreciate any advice anyone may have.

Thank you.


Can you try this in FF

Thanks for the suggestion

I’m at work now but will try this when I get home tonight. Are you thinking its some kind of DNS issue?

Indeed I am
If this system is a new install and has not been updated it may be subject to a bug in the initial release.
AFAIK, that bug is now fixed. Deleting
/etc/resolv.conf was usually enough to fix the problem.

It is a new installation but i connected via ethernet and let the updater do its thing … so I assume its fully patched.

I will try typing in a sites IP rather than a URL to see if it is indeed DNS related. I’ll post back tonight with the result.


Just thought, If I can browse the web using a wired connection then its probably not going to be DNS

Correct. Sorry.

Check this
HCL/Network Adapters (Wireless) - openSUSE


Getting Your Wireless to Work - openSUSE Forums

Will check them out. Thanks for your help

I read through the links but noticed that my wireless adapter worked out of the box on my ubuntu 9.10 desktop. I installed 9.10 on the laptop and the adapter worked straight away without any messing. This is a shame because I would have liked to try another distro like opensuse but it was a bit beyond me at the moment.

Thanks for your efforts though