Working deamon won't start at boot up

Hi,

I’ve got a working daemon for mediatomb on my SUSE 11 box. If I start (enable) it in Yasta “System services” it fires up mediatomb no problem. If I stop it in Yasta it stops ok.

If I enable it (to start automatically) and reboot, the deamon does not kick off mediatomb when the system is booted. I checked with ps -ef | grep media and it does not appear. If I check the mediatomb log (var/log/mediatomb) there is nothing logged at startup at all.

I’m confused by this because I know the daemon works ok (see first paragraph) so why won’t it start at boot? :stuck_out_tongue:

Hi
Is the startup script based on the /etc/init.d/skelton file? If not in
your startup script do specify the full paths to the applications and
have you created the softlinks in the rc directories?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 9:47, 1 user, load average: 0.09, 0.04, 0.05
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I didn’t create the script it came with mediatomb - I will check tonight though.

Is there anything else I can check there must be a “deamon” log somewhere that tells me whats going on ?

I was also thinking, as a test, of setting up a cron to stop and start the deamon just after boot up - in case mediatomb is starting to early or something. Is there a command line for stopping and starting deamons ?

Hi
I’m assuming here you downloaded the packman version? If so, when you
when into YaST to start the application, did you use expert mode and
enable the service there?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 1:20, 2 users, load average: 0.77, 0.69, 0.53
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Yes I downloaded mediatomb from Packman.

I set it to running in “System Services (Run level)”. It has a run level of 3 and 5. Is this what you mean?

I’ve fixed it.

I just needed to add -i and my IP address into the MT_OPTIONS in /etc/mediatomb.conf.

All now working.

Hi
Glad you go it working, I see it does send a log to /var/log as
well :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 11:15, 1 user, load average: 0.00, 0.00, 0.02
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80