Working around Intel graphics in 11.1 and Factory/11.2

I’ve been testing out 11.1 and, when that failed to work well, Factory. Testing was done on a thinkpad X30 using i830 intel driver with kernel 2.6.30, xorg server 1.6.1, Mesa-7.4 with intel driver 2.7.0. None of the below allow accelerated graphics with no screen corruption or random hard locks on my system. Suspend/Resume hasn’t worked on 11.0 or later.

‘NoAccel’ ‘true’ added to the Device section of your xorg.conf will work on most models. That kills DRI and accelerated graphics but only damages individual programs that need that and slows down window redraws. For example, I’m trying to learn OpenGL and whenever certain glut functions are used there is a segfault as the Mesa software rasterizer is accessed improperly(guess as glut functions work fine with XAA and EXA).

‘AccelMethod’ ‘XAA’ is the older method and crashes at random intervals and fails to update window contents properly until after I run glxgears.

‘AccelMethod’ ‘EXA’ along with the ‘EXANoComposite’ option set to true or false may work for some. When EXANoComposite is disabled areas of the screen get smeared along with fonts. Enabled redraws areas of the screen slower but has less screen corruption. Both crash.

‘AccelMethod’ ‘UXA’ requires ‘Tiling’ ‘off’ to start X and has a lot of screen corruption and crashes. In addition VT switching no longer works. I am not certain I was able to start UXA properly. I believe that I need to rebuild the i915.ko and drm.ko drivers with KMS(kernel mode switching) enabled and suspect those drivers were not built with KMS enabled. Will likely need to build a custom kernel to test properly.

‘ForceEnablePipeA’ added to all of the above seems to have an effect though I’m not sure what the effect is.

Suspend/Resume from X always results in a hard lock. From a terminal with the drm module unloaded (X not running) results in a black screen with the keyboard and system running. I can enter commands and see the result from leds or affected system. For example, turn led on using keyboard command touch typing instead of FN-?? or /sbin/reboot.

I will likely be testing other oses on this laptop, most likely freebsd and opensolaris, as all the distributions are suffering from the same issues with intel graphics.

It seems to be the driver you need some kind of legacy fix now Arch a bleeding edge distro feel the need to include one<Shrug>. I presume as they think it is needed due to the many complaints.

I’ve done my best to break the legacy fix down for someone to try here Old intel i810 Driver… - openSUSE Forums yet no one has tried it yet…