Workaround for bug 432159

Dear All,

I am experiencing a manifestation of the bug 432159 when trying to upgrade from openSuSE 11.0 to 11.1, using an installation DVD. I mention that I had no such problems when installing the 11.0 (fresh installation).
For reference:

I’m rather new to both Linux and openSUSE. Can tou help me with a workaround?

Thanks in advance,


I checked the bug you mentioned but I still don’t understand your issue very well. The bug in Beta2 was about the Verify Installation option in the DVD not working. I used the Verify Installation option in the final release version of the 11.1 DVD and it worked fine. To ensure the best quality in burning your DVD use the slowest burning speed possible. Also make sure you have a perfect ISO image, by downloading the md5 file into the same directory where your image is and running

md5sum -c openSUSE-11.1-DVD-i586.iso.md5

If you verified your image and burned as slow as possible and you still get an error with the Verify option, here is a work-around to verify the MD5 sum of your burned DVD.

The DVD always contains some extra bits at the end after the image. These are harmless, but they mess up a direct calculation of md5sum. So you need to apply md5sum to the exact length of the original image.

I will assume you are in the directory where your openSUSE-11.1-DVD-i586.iso is. Find out the device associated with your DVD using the command ‘mount’. In my case I get
/dev/sr0 on /media/SU1110.001 type iso9660
, which means my DVD is on /dev/sr0.

To verify the ISO on the DVD run the following:

dd if=/dev/sr0 | head -c `stat --format=%s openSUSE-11.1-DVD-i586.iso` | md5sum

Adapt the device number to your case and notice that I used back-single-quotes (better to copy and paste). If the result from md5sum is the same as what is in ‘openSUSE-11.1-DVD-i586.iso.md5’, your DVD is OK.