wont boot into GUI

the install seemed to go alright, but when it restarts, it boots to the command line and asks for my login and password, i type them in and it says “have fun” or something then just stays at the command line…it wont boot into GUI, is theres something i can do? im pretty new to linux so please help! thanks :slight_smile: im running it on a emachine t2958, 2.4ghz celeron D, 1gb ram, integrated graphics(may be a problem)

I just installed some updates for 11.1. now I have the same problem.

Hopefully you remember the username and password that you gave when you installed? by defualt you have a super account called root and one with a name of your choice, both with the same password of your choice.

When you have logged in type “startx” to start x-windows, the GUI.

My problem is that since my last repo-update this fails.

Sometimes a repos update will result in a kernel update, where the graphic driver one is using does not work with the new kernel.

If that is the case, an interim approach that works some times is to 1st backup one’s graphics configuration file, and then 2nd use either the VESA graphic driver or the openGL graphic driver , until one can sort their problems with the proprietary graphic driver.

One can do that by 1st logging on as a regular user at the text prompt.

Then type “su” (no quotes - enter root password) to get root permissions.

They backup the graphics config file with:cp /etc/X11/xorg.conf /etc/X11/xorg.conf.newbackupthen one can see what graphics they have by typing:
sax2 -pAssuming one’s graphic device is chip:0, then to load the vesa driver type:sax2 -r -m 0=vesa
(if one’s graphic device had been chip:1, I would have suggested “sax2 -r -m 1=vesa” ).

Then type “exit” to get rid of root permissions. Once one is back to a regular user, simply then try “startx”.

For this first time, to restart, simply type (with root permissions) “shutdown -r now” … or to shut down type “shutdown -h now” … Afterward that should not be necessary.

With the basic gui back, it may be easier for most users to then sort their proprietary graphic driver.

For some reason your machine is starting as init 1 or init 3. As root try:

init 5


tellinit 5

it should start your GUI bringing it to live again, reactivating your X11.

If it is a new a new installation, just do it again should solve. Otherwise, you can also go to X11 as root and reconfigure it, or if you have a nvidia card, just run the graphic card installation. :slight_smile:

when i type startx i get “no startx installed” =( whats going on!! and when i type sax2 -p i get sax2 command not found =(


You need to run those commands as root.

When that login and password prompt comes up use

login: root
password: whatever your root password is

then you can use those commands.

Good Luck,


i tried them as root, some thing happens. when i tried reinstalling again, but everytime it keeps saying that 1 of the .rms are missing. i cant remeber which one… but is there a way to find out what im missing and repair it from the command ??

oldcpu, thanks for the help.

I am still not getting past a console, though. I have tried; -

  • what you said. (It was chip 0)
  • safe mode at the first menu (GRUB, I think it is called). I get the same.
  • I have tried tried “startx” from the console. The very first time that I did this, there was some text, which I missed. Now it just goes to a very broken looking screen with dots, blocks and flashing bits. My caps lock light is flashing (whimpering) at me to tell me how poorly the machine is. I cannot get any of the alt-crtl-F* consoles. I have to hold the power button in for 10s to force a power down.
  • I read dmesg. I may have missed something, but could not see anything relevant.

Anything else I can try? Is it possible to simply undo the last repo-update, for example?

I have a Toshiba Satellite laptop with an ATI graphics card, BTW.

I must apologise for hijacking neopan89’s thread. I originally thought we might have related issues.


Before typing “startx” did you type: “sax2 -r -m 0=vesa” ? And after that finished, did you then type “exit” and confirm you are no longer root? ie type “whoami” to confirm you are no longer root. ONLY AFTER you are no longer root should you try “startx”.

This can be a pain when it flashes by so fast. I have taken to having my digital camera next to my PC when doing such things, and as soon as I press the “enter key” for such activities, I press the “movie record” feature on my digital camera. Thus I take a short movie clip of things, and I can see the error messages that way when I play back the video.

BUT with my having stated that, my knowledge is often not good enough , and often I do not have a clue as to what the error messages mean. :slight_smile:

Yes there are many things you can try. What model Toshiba?

You could try booting with ACPI kernel setting (there is grub menu setting you can apply for that). SDB:Kernel Parameters for ACPI/APIC - openSUSE

You could also try to kick start one of the openGL drivers (with an appropriate sax2 command that I could guess at) , although IMHO the vesa driver should work …

It tok me a while to find the time. When I did the SaX2 thing I was losing the display. I SSHed in and got this.

linux-hvlf:~ # sax2 -r -m 0=vesa
SaX: initializing please wait…
SaX: your current configuration will not be read in

SaX: no X-Server is running
SaX: will start own server if needed
SPP: prepare device [0] profile: FireGL.addon
SPP: prepare device [1] profile: synaptics
SPP: including prepared profile(s)…
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)…

SaX: startup

xc: sorry could not start configuration server
xc: for details refer to the log file:


xc: abort…

linux-hvlf:~ #

I have put the log here:

Any more ideas?

What did you update in your last repos update? I’ve read of some problems with the kernel (and encountered some myself).

If this was a kernel update that “did this” to your PC, you could consider rolling back to the kernel that came with openSUSE-11.1.

OK, I am happy to try that. What is the correct way to do that?

(so that, for example, YaST is aware of it, so that next time there is a kernel update, it can be applied in the usual way).

The correct way? I probably can not help you there. The way that I do this, may confuse a new user, and may be looked down upon by a more advanced user.

So I will state how I would do it, but you need to find your own way.

If it were me, I would

  • backup the /boot/grub/menu.lst file and also any appropriate /etc/X11/xorg.conf file.
  • ensure I had all necessary drivers/modules for the kernel that I was abot to install (possibly the same - it depends on the graphic driver that is used]. There is a reasonable likelyhood these are all on the installation DVD or in the OSS respository. If you do not know what that means, then post and ask (it takes time and some typing to explain). Some users require custom alsa rpms, so if you were one, ensure you have the rpms for the older kernel. … etc …
  • type “rpm -qa | grep kernel” to see what kernel rpms I had installed
  • download the older kernel rpms (as applicable, using the information gained from the previous step) from the OSS repository [again, if you don’t know what OSS repository means, then post. It takes time and a lot of typing to explain];
  • install the older rpms with the "rpm -ivh kernel-a kernel-b kernel-c etc … " type command. I would choose “ivh” as the options so as to keep the current kernel while I installed the original kernel. This will create a dual boot. Other users may simply replace the kernel (doing this different). It also may be necessary to remove the new kernel-source and kernel-syms to avoid dependency problems.
  • BEFORE rebooting, check the content of the updated /boot/grub/menu.lst file to see it makes sence with the new kernel. The old backed up /boot/grub/menu.lst can be used as a reference, but NOT as a replacement.
  • reboot, and then try setting up the GUI again. Its possible some of the older /etc/X11/xorg.conf files (especially if good clearly labelled backups were kept) can come in handy. I try to keep good clear backups.

Are you also certain this is a kernel update problem? What does "uname -a " give? Are you on a new or an older kernel version?