Won't boot after updates

I’ve been running Leap 42.2 on my HTPC for a while now. Installation was pretty easy. I came back to openSUSE after a brief dalliance with Ubuntu that went sour. :wink: I used to know so much more about linux than I do now. So I’m stuck because I don’t even remember what is the first thing I should do to start troubleshooting.

So I’ve been running 42.2 Leap (64-bit). A few days ago I got the notification that there were updates. I installed the updates. The updates required logging out. I rebooted. Since then, the machine will not boot. I get to a text screen that shows the status of some processes, the contents of which is:
Starting Accounts Service.
OK ]Started X Display Manager.
[FAILED] Failed to start Postfix Mail Transport agent.
OK ] Started Command Scheduler.
OK ] Reached target Multi-User System.
OK ] Reached target Graphical System.
Starting Update UTMP about System Runlevel Changes…
OK ] Started Update UTMP about System Runlevel Changes.
Starting Authorization Manager…
<can’t read a bit here>
OK ] Started Accounts Service.

So when it gets to that screen, it flashes between that screen and a black screen several times. Then it just stops on that screen and all disk activity stops.

I’ve tried starting with Advanced options and loading previous kernels, but I get the same results with every one of them (there are 5 or 6 available). I did get it to boot once using the “Start bootloader from a read-only snapshot” and selecting openSUSE Leap 42.2. In there, I checked the boot.log file, but it looked fine. No obvious problems. I’m thinking though, that that file might be just from the read-only snapshot, not from the normal system (kinda like when running system recovery, the system files are from the recovery, not from the installed system). Is that right? I’ve tried doing that again to get into the system, but subsequent tries using “Start bootloader from a read-only snapshot” exhibited the same behavior.

I’ve got a recovery USB drive, and can boot into recovery, but once I do, what do I do then?