WOL Wake-on-Lan mit Asus M2A-VM unter OpenSuse 10.3


Ich habe einen Fileserver mit OpenSuse 10.3 und letztens ist das alte Mainboard defekt geworden.

Jetzt habe ich ein Asus M2A-VM (nicht HDMI) eingebaut, doch ich bekomme Wake-on-Lan nicht hin.
Ich habe auch schon beide Treiber (r8169 von OpenSuse10.3 und den r8168 von Realtek) probiert, aber mit beiden klappt das nicht.
Auch das ethtool -s g eth0 in halt.local und als POST_DOWN_SCRIPT habe ich probiert - leider ohne Erfolg.

Ein Suspend to Disk funktioniert nur einmal…

Ich wäre für jede Hilfe dankbar :slight_smile:


P.S.: BIOS 1803

Bitte, kanst du auf Englische schreiben,die meisten uns sprechen nur Englisch auf dem Forum


Hallo Marcus,

ich mach mal auf Englisch weiter, wie deltaflyer schon sagte, sprechen die meisten hier Englisch und das erhöht Deine Chancen auf eine gute Antwort. Falls das ein Problem ist, sag es.

WoL isnt working with an Asus M2A-VM.
Opensuse 10.3
Drivers: Neither the r8169 nor the r8168 from Realtek allow WoL)

Please run
ethtool eth0
and post the output here. I assume your NIC does work else, right



Ok, sorry for the confusion, I thought there is a german section.

Yes, the interface is working.

Here is the output from ethtool eth0:
Settings for eth0:
Supported ports: TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

As said, I tried two kernel modules: r8168 and r8169.
What I now got working is “Suspend to Disk”: then I can use wol - but only once :confused: And after restart, the local PS2 keyboard does not work anymore.

Another problem was that using 1000 MBit speed resulted in bad samba performance - ACDSee on Windows took ages to show images from the server. This problem was gone as soon as I added a 10/100 Switch. So I think it is an issue with the GBit mode. That was the initial reason to use the r8168 driver.

But now my main issue is the wol. I’d appreciate if any one could help me in solving this.


On 07/24/2008 mmmchen wrote:
> Supports Wake-on: pumbg

Looks like it supports pretty much everything. What did you do to try and wake it up?
The fact that it works with suspend to Disk indicates the PSU cuts off the NIC completely. When you power down the machine, do you still see a light by the UTP connector indicating a network cable connect? I vaguely recall we have dealt with a similar problem in the novell forums.

As for the Gigabit problem: Check if your cable isn’t a very cheap one. Gigabit connections need good cables. Else consider starting a new thread on this problem.

As for the language: We consider starting language specific forums. If you have an opinion on this, I’d appreciate if you talk to us about it in the “general” forum. Feel free to drop me a private message.


To wake up I try two variants, winwake from windows and wol from linux. The windows version was used before to wake up the old board (different MAC :-). Now the server is still in the same housing, so the PSU is the same as with the old board.

No, after shutdown, the LED is not lit any more. I checked that, but I do not know how to prevent the PSU from switching off.

And the suspend to disk is no option as it only works once.


On 07/24/2008 mmmchen wrote:
> No, after shutdown, the LED is not lit any more. I checked that, but
> I do not know how to prevent the PSU from switching off.

Argh, that’s what I was afraid of. No power, no WoL. This is a common problem (you’ll see when you google for it) and I haven’t found a solution to it. My ASRock board (NVidia chipset, two NICs onboard) behaves similarly.

What you can try:
-Disable power management for your NIC in Yast’s NIC configuration.
-Play with BIOS settings
-finally, use a cheap NIC known to work and abuse it to just turn the machine on

Good luck

Ok there are a few issues here:

Does the PSU supply standby power in, er…, standby? Have to look at PSU specs plus the cables to the mobo. If you have a multimeter, that would be handy too.

Is there a feed for this standby power line to the NIC? In older NICs supporting WOL, this was through an extra cable. In newer NICs, there is a PCI bus line for this, plus the power on trigger line. Only reading the specs of the mobo and the NIC can you tell.

If you can get the NIC’s LED to be lit in standby, then maybe you have a chance.

I did not manage to get the LEDs on the NIC lit after shutdown.

With further HW investibgation, I found that my PSU only has a 20pin power connector and a 4pin connector. But the mainboard has a 24pin and 4pin; so 4 of the 24 pins are not used. Could this be the power supply for standby operation???


No, 20 pins has standby power line also.

Is anything lit up on the motherboard when the machine is shutdown but the power supply is not turned off? If so there is standby power. Question then is whether it is getting to the NIC and whether the NIC is able to make use of it.

In another thread about WOL the poster found that a newer driver released by the manufacturer fixed the problem. Maybe this is also true of this model?

I already tried the Realtek 8111/8168 driver, but no difference…



I already tried the realtek driver for the r8168, but with not difference…

Yesterday I checked for the mainboard when power is down and there is a LED lit, so the board has standby power. But I also can not power-up via mouse or keyboard (enabled in BIOS) (There is a Raritan KVM inbetween).

Any ideas?


I’m using Asus M2A-VM HDMI together with openSUSE 10.3 and for me WOL is working. I just added the following lines to /etc/init.d/halt.local:

ifup eth0
/usr/sbin/ethtool -s eth0 wol g

If this doesn’t help, just check your BIOS version. As far as I can remember I needed to upgrade BIOS to version 1603 to get WOL working.