WOL How to make work?

Trying to enable Wake on LAN.
Not a pro by any means, but have done some reading:

Steps I did:

  1. enabled WOL in bios
  2. set static ip for the computer (x.x.x.134)

linux-f5tb:/home/Kilbert # ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether d0:<cut>2f:<cut>:ff
    inet <cut>.134/24 brd <cut>.255 scope global enp5s0
       valid_lft forever preferred_lft forever

  1. checked if adapter was set to ā€œgā€
linux-f5tb:/home/Kilbert # ethtool enp5s0 | grep Wake-on
        Supports Wake-on: pumbg
        Wake-on: g

  1. tried 2 different android apps and it does not work (Wake On Lan (which works on my PC at work) and Fing):
  2. booted PC manually and checked/verified packets arrived with wireshark:

from wol app:

153    11:59:02.272034901    <cut>.1.104    <cut>.1.134    WOL    144    MagicPacket for AsrockIn_99:<cut>:2f (d0:<cut>:2f)

repeats multiple times

from fing:

4607    12:15:17.093251889    <cut>.1.104    <cut>.1.255    WOL    144    MagicPacket for AsrockIn_99:<cut>2f (d0<cut>:2f)

I noticed the IP is different (both apps auto detect) however neither work

Any help is appreciated

I did not check if you did everything OK (though it does not look to bad to me). but want to warn you that even if it is on in the BIOS and is set with ethtool, the hardware might still not be able to support the feature.

My experience is that it is not always easy to find out if the hardware supports it. Information on the web-site of the manufacturer about this might be missing and help desks, well, help desks ā€¦

As far as I understand it, the LAN card may support it (that is why ethtools can set and show the setting), but a crucial connection (a wire) between the hardware and some other point on the motherboard might be missing.

Second IP is broadcast.

(both apps auto detect)

Application cannot detect IP when host is switched off (which is when you actually need to use this application) and in my experience using broadcast often does not work, so try explicitly configure your app to use host IP.