WMP54GS is driving me insane!

Hey everyone, just installed SuSE 10.3 and I’m slowly becoming addicted… if only I could get this stupid card working.

I installed the drivers for the WMP54GS… and according to ndiswrapper they work. My only concern is that some people said they were using a bcmwl5.inf driver but when I download the drivers from Linksys the folder contains only a bcmwl5.sys file and the matching wmp54gs.inf file.

Nonetheless, the wmp54gs.inf file installed and ndiswrapper -l says:

driver detected (alternate driver bcm43xx)

It does not say hardware detected though and that seems to be my problem. My wireless lan card does not light up and stays inactive after numerous reboots and configuration tries.

In YaST, it seems that my card is detected when it really isn’t.





Any ideas? I’ve tried blacklisting the bcm43xx, I’ve edited the config files of modprobe to allow for this card… I’m worried that I’ve tried so many different tutorials that my config files are all screwed up now. But despite all I’ve tried I’ve never been able to get this wlan to be active. It works fine in Windows, as I’m dual-boot.

I’m using SuSE 10.3

I don’t say that this is it, but give it a try:

I do not use Network manager and I would disable IPv6.

do as hcvv says, disable IPv6, however…if on 10.3 and using the bcm43xx driver as i think you said above, install this patch


you need the 2nd one down. try that.

Please be careful with personal, private, or secure information, as this is a security risk.

Oops I forgot to block out those pics… Is there any way to edit that post?

Anyway I’m going to try that patch and disable IpV6… I’m a bit of a beginner how would I do this?

And I’m not sure what the BCM43xx driver is… is that a generic Wlan driver? It’s not the one I want to use. I need the BCMWL5.inf… I installed that one but it says the bcm43xx is an “alternate driver”.

I will try that patch as soon as I figure out how to disable ipv6

That is the x on your last picture whre it says “Enable Ipv6” (your are awake aren’t you :rolleyes: ) and the ifup vs. Network manager is right above it.