wma plugin for firefox

Is there a plugin available for playing .wma files in firefox?
I’m using opensuse 11.1 (64bit) with KDE1/3.

firefox is:
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042700
SUSE/3.0.10-1.1.1 Firefox/3.0.10

Thanks!

Follow this guide and you’ll be fine
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Check this for amarok
http://forums.opensuse.org/how-faq-read-only/unreviewed-how-faq/409491-flash-k3b-amarok-install-guide.html#post1953899

I’ve followed the guide, and it is very helpful. I can play .wma files and
videos in a stand-alone player, but firefox plays only flash-embedded
multimedia files.

I also checked the link from the page you referenced. Below is the output
per the instructions on that page.
tom@minuet:~> rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’
xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort
gstreamer-0_10-0.10.23-42.pm.1
gstreamer-0_10-ffmpeg-0.10.7-42.pm.1
gstreamer-0_10-fluendo-mp3-0.10.10-42.pm.1
gstreamer-0_10-fluendo-mpegdemux-0.10.23-42.pm.1
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
gstreamer-0_10-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-bad-0.10.12-42.pm.1
gstreamer-0_10-plugins-bad-lang-0.10.12-42.pm.1
gstreamer-0_10-plugins-base-0.10.23-42.pm.1
gstreamer-0_10-plugins-base-lang-0.10.23-42.pm.1
gstreamer-0_10-plugins-good-0.10.15-42.pm.1
gstreamer-0_10-plugins-good-extra-0.10.15-42.pm.1
gstreamer-0_10-plugins-good-lang-0.10.15-42.pm.1
gstreamer-0_10-plugins-ugly-0.10.11-42.pm.1
gstreamer-0_10-plugins-ugly-lang-0.10.11-42.pm.1
gstreamer-0_10-schroedinger-1.0.5-2.20
gstreamer-0_10-utils-0.10.21-3.13
gstreamer-utils-0.10.21-3.13
libavc1394-0-0.5.3-129.6
libavcodec52-0.5-0.pm.3
libavdevice52-0.5-0.pm.3
libavformat52-0.5-0.pm.3
libavutil49-0.5-0.pm.3
libgstinterfaces-0_10-0-0.10.23-42.pm.1
libgstphotography-0_10-0-0.10.12-42.pm.1
libgstreamer-0_10-0-0.10.23-42.pm.1
libpostproc51-0.5-0.pm.3
libswscale0-0.5-0.pm.3
libvlc2-0.9.9a-0.pm.0
libvlccore0-0.9.9a-0.pm.0
libxine1-1.1.16.3-0.pm.2
libxine1-codecs-1.1.16.3-0.pm.2
libxine1-gnome-vfs-1.1.16.3-0.pm.2
libxine1-pulse-1.1.16.3-0.pm.2
MPlayer-1.0rc2_r29116-2.pm.2
phonon-backend-gstreamer-0_10-4.2.0-40.18
phonon-backend-xine-4.1.3-4.2.9
vlc-0.9.9a-0.pm.0
vlc-noX-0.9.9a-0.pm.0
vlc-qt-0.9.9a-0.pm.0
xinetd-2.3.14-129.35
xine-ui-0.99.5cvs-20090203.pm.0821
tom@minuet:~>

Eureka!
I just got it. I just saw “mplayerplug-in” in the results of a search for
“mplayer” behind this reply (knode) window. It looked like it was what I was
looking for, so I installed it, and it works!

Thank you very much. I can go to bed now.
:slight_smile:

caf4926 wrote:

>
> Follow this guide and you’ll be fine
> ‘Multi-media and Restricted Format Installation Guide - openSUSE
> Forums’ (http://tinyurl.com/d6onhy)
>
> Check this for amarok
> http://tinyurl.com/cbstlt
>
>

Great - well done! Let us know if there any more issues.