wlan0 is down

After executing glxgears, my laptop got crashed.
I pressed Power Button and I turn it off. When I turn on the system again, the wlan0 dosent work.
I tried:

iwlist wlan0 scan

The result:

wlan0     Interface doesn't support scanning : Network is down

I tried:

ifup wlan0

The result:

    wlan0     device: Intel Corporation
PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    wlan0     warning: using NO encryption
RTNETLINK answers: No such file or directory
Starting DHCP4 client on wlan0. .
    wlan0     DHCP4 client NOT running
RTNETLINK answers: No such file or directory
Cannot enable interface wlan0.
interface wlan0 is not up

Your wireless card doesn’t like sleep mode. This is a common problem. What happens is when you press the power button that does not reboot the computer it only does what is called either suspend-to-ram or suspend-to-disk. Either way the system state is saved and portions of the system are powered down. This allows resuming without going through a boot process. The problem is, as you have descovered, sometimes parts of the system have forgotten how they are supposed to act.

The short term fix is to reboot your computer. In Konsole type sudo /sbin/shutdown -r now. Hopefully after the system reboots your wireless will be back to working. If not then try back here again.

If rebooting fixes the problem then we need to fix your power-down settings. Power management is handled by what is called the acpi subsystem. Acpi problems are not my specialty. If you continue to have problems with suspend-to-disk then you would need to post a question the the boot-problems forum on this site.

It happened 3 days ago and I tried rebooting and halting down the system many times. The problem persists!

On 02/28/2010 11:36 PM, sina saeedi82 wrote:
>
> It happened 3 days ago and I tried rebooting and halting down the system
> many times. The problem persists!

Is your wireless switch off? Check the output of dmesg.

Ok, now I’m confused. Is wireless working at any time? Does it work after a hard shutdown? (That is, holding the power button down till the computer powers down.) Or, does the problem only occure after sleep mode? ( Just pressing the power button once and letting the screen power off. )

If you could follow the troubleshooting proceedures in the stick thread at the begining of this forum and post the results here then we could start tracking down your problem.