Dear all,

I have installed open SUSE 11.0 in my laptop (compaq Presario V2000). I want to configure WLAN in this laptop to connect with other LINUX driven LAPTOPS.
How can I ensure, i have proper driver installed in my laptop ?
I am not getting wlan0 device in “ip a” output.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet brd scope host lo
inet brd scope host secondary lo
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:16:36:76:bf:1c brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:16:6f:ab:99:44 brd ff:ff:ff:ff:ff:ff


my wireless card is getting detected …

lspci |grep -i wireless

06:06.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

it won’t be called “wlan x”; you should find it’s eth1.

easiest way is have a look in yast under network settings, check the setup of eth1 and if it’s using the ipw2200 driver then that’s the one !

use yast config to set up the interface (probably starting by disabling ipv6 !)

if you want to do it all at cli instead then come back for + info :wink:


thanks for the reply

i have checked yast->network setting
it is using ipw2200 driver for eth1
i have also disabled IP6 for eth1

now how can i connect my laptop to a vista loaded laptop (here WLAN is working fine) ?
will it automatically detect the WLAN network? or i have to do a bit more ?


now how can i connect my laptop to a vista loaded laptop

if I understand that question correctly then first step is to connect to your wireless network:

you will need to configure access point (SSID) and any security password/passkey; assume the network uses dhcp to provide ip address, routing etc? if not that will have to be set as well

those settings can be applied from yast>network settings, choose the eth1 interface, “edit” and add the necessary information.

or if you’ve chosen to use network manager, same info can be added to a eth1 profile there

at which point you should be able to connect to the network

I’m assuming from your previous posts, you didn’t need a “step-by-step” on setting up a lan interface?