wlan with wpa on Thinkpad T41 and Opensuse 11

Hello People,

I’m Owner of a IBM Thinkpad T41 with an Intel Pro/Wireless LAN 2100 3B Mini PCI Adapter and a 88w8335 Libertas 802.11b/g Wireless Adapter.
First, all components are working but i’m only use the Libertas Adapter. I tried both adapters as well.

My problem is that the adapters are working without any ciphering and with WEP.
But i tried WPA personal and here is my problem.

In YAST and on the router i enter all my datas with SSID, WPA personal, Passphrase. Now i setup a new connection on the controllpaneel witch is layed on the bottom of my display.
I select my WLAN and now i must enter my datas again (courious) So then i save all and push the button save and connect. …nothing is happend, so i edit this again and and instead my 13 characters is now a 64 charakters series wich is every time i change the same. So i belief that is a translation of my 13 characters.

My question is how can i told the setup on controllpaneel that he must use my 13 caracters.
And by the way i tried out to setup all with the 64 caracters my router told me he need all between 8 and 63 characters.

Anybody who can help me!!!