WLAN not working!

I’ve hp pavilion DV9700 notebook. just installed Opensuse with KDE and tried following driver for WLAN

udi = ‘/org/freedesktop/Hal/devices/pci_14e4_4328’
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘pci’
info.linux.driver = ‘b43-pci-bridge’
info.udi = ‘/org/freedesktop/Hal/devices/pci_14e4_4328’
info.subsystem = ‘pci’
info.product = ‘BCM4328 802.11a/b/g/n’
linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:0c.0/0000:03:00.0’
info.parent = ‘/org/freedesktop/Hal/devices/pci_10de_45a’
pci.linux.sysfs_path = ‘/sys/devices/pci0000:00/0000:00:0c.0/0000:03:00.0’
pci.product_id = 17192 (0x4328)
pci.vendor_id = 5348 (0x14e4)
pci.subsys_product_id = 4967 (0x1367)
pci.subsys_vendor_id = 4156 (0x103c)
pci.device_class = 2 (0x2)
pci.device_subclass = 128 (0x80)
pci.device_protocol = 0 (0x0)
pci.vendor = ‘Broadcom Corporation’
info.vendor = ‘Broadcom Corporation’
pci.product = ‘BCM4328 802.11a/b/g/n’
pci.subsys_vendor = ‘Hewlett-Packard Company’
pci.subsys_product = ‘BCM4321 802.11a/b/g/n Wireless LAN Controller’

Can someone help me selecting/installing right driver for my WLAN?

Firmware is installed?
https://forums.opensuse.org/english/get-technical-help-here/wireless/484106-broadcom-firmware-needed-b43-but-i-have-no-network-easierwork-around.html

Thanks for quick reply! I’ve applied your solution but status is like before:(. Wireless tab is disabled in network manager and traditional method in network devices with ifup also don’t help. Any other suggestion?

Are you sure NetworkManager is actually running?
Try to enable it in YaST->Network->Network Settings.

And there is a bug in openSUSE 12.3 that it may not be correctly activated on a fresh install (or both NetworkManager and ifup networking may be activated at the same time which causes troubles of course).
Please check this: openSUSE 12.3 Release Notes


I think its activated. I’ve pasted screenshots of networkManager.

http://susepaste.org/2831065

http://susepaste.org/16438989

Sorry, that doesn’t work.
You have to upload the screenshots somewhere, e.g. SUSE Paste and post the link here.

updated screenshots!

http://susepaste.org/2831065

http://susepaste.org/16438989

And which openSUSE version are you using actually? That KDE decoration on your screenshots looks a bit older…
Also YaST is themed now since a few releases.

But yes, NetworkManager seems to run correctly.

Its OpenSuse 11.3

Well, that’s quite old and out of support since January 2012.

Maybe the firmware package from Packman would help? (still available for 11.3)
PackMan :: Informationen zum Paket b43-firmware

Or you could try using ndiswrapper with the WindowsXP driver, but I can’t help you with that, sorry…

And another thing regarding NetworkManager:
On my system (12.3, haven’t used WLAN in 11.3 times) the WLAN tab is enabled even if I disconnect my WLAN-Adapter. But a WLAN connection has to be configured for that tab to be enabled.

After installing the firmware and rebooting, have you tried to click on “Add…” and add a WLAN connection?