Wlan in Suse 10.3 with ndiswrapper

Hi there,

i’ve got an old ThinClient with Suse 10.3 and a custom Kernel

Now i wan’t to integrate this machine in my wlan. So i compiled ndiswrapper 1.54. modprobe ndiswrapper gives no error. But there is no Interface in Yast. If i add it manual to yast (type wireless and modul ndiswrapper) i got it listet with not connected. The interface makes no connection to my wlan. It seems to me the wlan0 interface and the wireless interface in yast are not linked together. Here are some Outputs, i hope you could help me.


Bus 001 Device 005: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 001 Device 004: ID 046d:c312 Logitech, Inc. 
Bus 001 Device 003: ID 0557:7000 ATEN International Co., Ltd 
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 0000:0000  


Module                  Size  Used by
cpufreq_conservative     5264  0 
cpufreq_ondemand        5632  0 
freq_table              3028  1 cpufreq_ondemand
snd_pcm_oss            31968  0 
snd_mixer_oss          12320  1 snd_pcm_oss
ndiswrapper           160232  0 
snd_cs5530              3796  0 
snd_sb16_dsp            7136  1 snd_cs5530
snd_sb_common          13568  2 snd_cs5530,snd_sb16_dsp
snd_pcm                58328  2 snd_pcm_oss,snd_sb16_dsp
snd_timer              15988  1 snd_pcm
evdev                   7552  1 
snd                    38356  7 snd_pcm_oss,snd_mixer_oss,snd_cs5530,snd_sb16_dsp,snd_sb_common,snd_pcm,snd_timer
soundcore               5236  1 snd
snd_page_alloc          6776  1 snd_pcm


wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:1256.85 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:20 dBm   Sensitivity=0/3  
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ndiswrapper -v

utils version: '1.9', utils version needed by module: '1.9'
module details:
filename:       /lib/modules/
version:        1.54
vermagic: preempt mod_unload GEODEGX1 

ndiswrapper -l

net8187b : driver installed
	device (0BDA:8189) present

dmesg | grep ndiswrapper

ndiswrapper version 1.54 loaded (smp=no, preempt=yes)
ndiswrapper: driver net8187b (Realtek Semiconductor Corp.,06/25/2008,5.1135.0625.2008) loaded
usbcore: registered new interface driver ndiswrapper

dmesg | grep wlan

wlan0: ethernet device 00:02:72:75:26:c1 using NDIS driver: net8187b, version: 0x1, NDIS version: 0x500, vendor: 'Realtek RTL8187 Wireless LAN USB NIC                                     ', 0BDA:8189.F.conf
wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK

And here how i installed ndiswrapper:

make install
ndiswrapper -i driver.inf
ndiswrapper -l > driver installed and Hardware present
ndiswrapper -m
depmod -a
modprobe ndiswrapper


I’d forget to say if i scan with

iwlist wlan0 scan

i got no result. If i scan with my Ubuntu Laptop i got 3 Wlans.

Try again associating the Access Point in Yast. Have a look at the pics in the segment titled Configure the Wireless Card Using Yast in the linked tutorial. The pics are for 11.0 but you should be able to translate them to 10.3. Ignore the stuff about installing ndiswrapper because you’ve done that already.


i checked out your link and all the options in this Howto. I everywhere had the same, so the problem is located anywhere else.


Got me puzzled. Did you use the vista or the xp driver?

i tried it out with the WinXP the Win2000 and the Win98 driver.

Greets Phil

Don’t really know how all this goes together but I noticed you said a custom kernel compile.

zcat /proc/config.gz | grep WIRE

Not a simple mistake here is it?

zcat /proc/config.gz | grep WIRE gives this:

# CONFIG_FIREWIRE is not set

greets Phil

And what is the make/model of the device, and a link to the product page perhaps? Plus the windows driver/s, did they come with the device or did you download?

Realtek RTL8187B-devices like yours are always problematic with older kernel versions (even with ndiswrapper).

If possible, upgrade to 11.1 in most cases your adaptor will work out of the box with 11.1 (kernel 2.6.27), if not you can install “compat-wireless” for 11.1 (compat-wireless for 10.3 and 11.0 will not work).

For an example, see this thread:


Hi there,

last week i was in Holiday so i can’t reply to your posts.

The Hardware is a IBM Netvista 2200 Thin Client. I’ve downloaded the drivers.

I can’t update to 11.0 because the Kernel didn’t boot. link to the Problem Description.

If anyone could help to bring the 2.6.27 Kernel running the Problem is solved cause the 2.6.27 brings a Kernel Module for the RTL8187B.