[wlan] deauthenticating from MAC-AD by local choice (reason=3)


right after updating suse 11.2 via wlan to 11.3 i could not connect to my WPA2 secured Wlan anymore. looking in dmesg i found:

wlan0: deauthenticating from 00:24:01:e7:94:75 by local choice (reason=3)

i found a lot of bugs messages relating to this, including the “fix” removing the network manger. i did remove it, but it did not help. i also removed wpa2 and tried with no encryption, but that showed more errors.
so i tried 11.1 live-cd and it worked flawlessly. then i tried kernel 2.6.35-rc3-6-pae from the factory repo. this did not help.

then, i got sick of reading without finding a bugfix and i edited the kernel source myself (no, not dangerous, and yes i knew what i was doing). i commented out line 2963 to 2966 in rivers/net/wireless/hostap/hostap_ioctl.c . well, that worked for the deauthenticating issue, but now i have 40% to 60% package loss in my wlan.
again i tried my 11.1 live-cd and it still worked.
then i compiled kernel 2.6.37 vanilla from kernel.org, but that, too, did not help…

kernel driver in use is: ath5k
for device
[pcmcia] - tp-link tl-wn610g

any suggestions?

Just a couple of thoughts for you. I have seen lots of success with users just disabling NetworkManager and using ifup instead, I found this to be true myself. Uninstalling NetworkManager and then reinstalling caused one folder to not be created for me the last time I tried this. I had to compare two different machines to find the missing file/folder so doing this is not suggested. On one computer I found that I had used some NetworkManager files from KDE4:Unstable repository. Restoring all files for NetworkManager from openSUSE:Update fixed the problem. I would open YaST / Software Management and search on NetworkManager and make sure all of the files come from openSUSE Update. I also heard that KDE users should load the NetworkManager Plasmoid to help.

In addition I have used the following fixes:

Doing the following commands have helped before:

sudo rm /var/lib/NetworkManager/NetworkManager.state

sudo /etc/init.d/network restart

OR try this:

Problem was solved acccording to one user after having removed these files:

rm ~/.kde4/share/config/networkmanagementrc

rm ~/.kde4/share/apps/networkmanagement

These are the most recent suggestions I have come across so far.

Thank You,

On 2010-11-17 02:06, brian j wrote:

> any suggestions?

That you try the wireless forum >:-)

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

any mod wanna move this thread?

On 2011-12-09 04:06, wildnux wrote:
> Has anyone found a solution to this problem? I am suffering from it.
> here is what i get with dmesg:

Why don’t you ask in the wireless subforum? That’s where the experts are.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

check command ipcs
in my case I had lost of shared memory allocated