Wirless gone after deactivating it

I don’t know who had this glorious idea of letting the wireless disappear from the desktop once you deactivate it (Yes that happens! I know OMG!! But there’s trains and other situations where it makes sense) but that guy should be prevented from reproducing.

How do I turn it back on?
Searching since 45 minutes in the settings. Google always leads to ubuntu people complaining about hard switch problems.

When you said you deactivated it, how did you “deactivate” it. Was this done thru a hardware switch mechanism or was this done thru the Destop Environment applet. Also, it helps to know what Destkop Environment you are using.

I am using openSUSE Tumbleweed, KDE Plasma Desktop on a Dell Latitude E6440 with a physical hardware switch. Flipping that switch “deactivates” the radios and when switching it back, the radios come back online and KDE automatically reconnects to my network.

Could you possibly give me some of your system information concerning this.

Please go into a terminal and type

ip a

Copy and paste it back here and we can go from there.

Cheers,
-Nathan

Okay I got it.
And I’ve calmed down.

But seriously, this is ****ed up and the reason why people stay away from Linux and prefer the easy life …

So:
It’s opensuse Leap 42.2
I clicked on the network manager applet thing in the bottom right corner. I turned off the wireless. And the manager was gone.

How did I get it back? Even more ****ed up:
I right click on the bottom panel -> “panel options” -> “add widgets”
I scroll down to “N”
Nothing there.
I click on that tiny search button on the top. I type “network”. I find that “networks” applet which is missing when I just scroll to “N”. I click it. Nothing happens.
I double click it. Now guess what?
In the bottom panel on the right side of the clock some “space” appears. No icon, it’s just space. Its transparent. I click it. Now I can reactivate wireless.
So now wireless is back but guess what? The icon appears on the left side of the battery icon. So now I have to delete that transparent icon on the right side of the clock.

Sorry for ranting like Linus but seriously, all I have to say to this behaviour is wtf …
To the developers:

  1. Don’t let the icon disappear when you deactivate wireless
  2. Don’t make it ridiculously hard to get it back, life is too short for this

I hope this thread saves all the others who are in a love-hate-relationship with linux some time …
Btw I’ve just retested it, same behaviour.

Cheers

To the OP: Please keep to the facts and leave the emotional rant out of requests for help. It does nothing to help attract the attention of those that can help. We’re all volunteers here, and for the most part regular users here just like you. If you want to rant we have a soapbox forum expressly for that purpose.

That is actually really odd behavior. I have many Leap 42.2 systems and one Tumbleweed system where this doesn’t happen to any of them. Here is a possible solution. Go into systemsettings > Desktop Theme and choose Breeze Dark. I have noticed with one of the themes the icon for certain things are missing.

It might be a long-shot, but give it a whirl and see if that helps out your situation at all.

Cheers,
-Nathan