wirelwss printer not found

I’ve an Epson XP-352 multifunction printer/scanner.
Wi-fi connections works (ping works), scanner (via wi-fi) works too. But when I try to add a printer it isn’t detected. Using AppSsocket/Jet direct and inserting IP when I check connection I get this error message:


/usr/lib/YaST2/bin/test_remote_socket: connect: Connection refused
/usr/lib/YaST2/bin/test_remote_socket: line 39: /dev/tcp/192.168.10.11/9100: Connection refused

Note that driver works because I can print using usb connection. And in Leap 15.1 it worked.

Are you certain that the printer supports that protocol? “Connection refused” usually means no service listening on the port. You can check what ports the printer is listening on with the nmap command.

nmap -sS <printer IP address>

The lpinfo command may also be useful

lpinfo -v

I would expect the Epson printer to support the IPP printing protocol.

No. This is what I did in Leap 15.1 and it worked.

Installed “nmap” package first then run run the command as root

giorgio@localhost:~> sudo nmap -sS 192.168.10.11
[sudo] password di root: 
Starting Nmap 7.70 ( https://nmap.org ) at 2020-07-10 11:39 CEST
Nmap scan report for 192.168.10.11
Host is up (0.000031s latency).
All 1000 scanned ports on 192.168.10.11 are closed

Nmap done: 1 IP address (1 host up) scanned in 1.75 seconds

Try a scan as per this thread

giorgio@localhost:~> sudo lpinfo -v
[sudo] password di root: 
network beh
direct ecblp:/var/run/ecblp0
network smb
network ipps
network ipp
network https
network http
network lpd
network socket


I would expect the Epson printer to support the IPP printing protocol.
May be useful to know that in Leap 15.1 this printer worked flawlessly using wireless connection.

If the firewall is disabled discovery should be possible.

I disabled firewall in YaST2 but printer isn’t detected.
Can you please give me a command line to check firewall state, just to be sure that it’s really stopped. Thanks.

As root:

systemctl status firewalld

Here, that shows the service as enabled. But for you it should show it as “dead” or “disabled” or “inactive” or something similar.

Here, I used ethernet to connect the printer. And I disabled firewall, configured printer, enabled firewall – which all worked.

Just after boot:

giorgio@localhost:~> systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
   Active: active (running) since Fri 2020-07-10 14:30:04 CEST; 4min 9s ago
     Docs: man:firewalld(1)
 Main PID: 1208 (firewalld)
    Tasks: 2
   CGroup: /system.slice/firewalld.service
           └─1208 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

and after stopping firewall in YaST2:

giorgio@localhost:~> systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Fri 2020-07-10 14:34:57 CEST; 4s ago
     Docs: man:firewalld(1)
  Process: 1208 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=0/SUCCESS)
 Main PID: 1208 (code=exited, status=0/SUCCESS)

then it seems firewall is disabled. But printer still non detected.

Make sure that the printer does have an IP address. I seem to recall that, setting up my network printer, it did not find the printer on first try. There was an option for extra/advance or whatever that found it.

This is ping with printer (and firewall running)

giorgio@localhost:~> ping 192.168.10.11
 PING 192.168.10.11 (192.168.10.11) 56(84) bytes of data.
 64 bytes from 192.168.10.11: icmp_seq=1 ttl=64 time=0.050 ms
 64 bytes from 192.168.10.11: icmp_seq=2 ttl=64 time=0.070 ms

I seem to recall that, setting up my network printer, it did not find the printer on first try. There was an option for extra/advance or whatever that found it.

Stop firewall and using “Detect more” found 4 items all related to printer. Choosing “dnssd” one I’m able to install and use printer.
Reboot and printer works only with firewall disabled.
Then firewall avoid detect and use printer.

Yes, the CUPS dnssd backend relies on the mDNS/DNS-SD port being open for discovery to work. However, you could easily manually configure the printer to use the ipp backend with the appropriate printer IP address (or its Avahi Hostname).

I will try.
What I don’t like is that firewall avoid printer connection.