Wirelss doesn't work. Can find Wireless LAN or UDI anywhere in Hardware.

I have an HP dm3t. I believe my wireless is Broadcom as I see it in the hardware under network. However, I have saved the entire Hardware file and ran a search and cannot find “Wireless LAN” or “UDI” anywhere, so I can’t even complete Sticky’s step one. I would attach the file, but I do not see that as an option here.
FYI, I ran Ubuntu prior to this, and it found the wireless right off the bat and after an update, it worked fine.

Here is the product info:
Broadcom 4313 & 2070 802.11 bgn WLAN + Bluetooth Combo card 621184-001

28: PCI 200.0: 0280 Network controller
[Created at pci.318]
Unique ID: B35A.8rd6TlLYjDF
Parent ID: qTvu.dK_ZWzocvA4
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:02:00.0
SysFS BusID: 0000:02:00.0
Hardware Class: network
Model: “Broadcom Network controller”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4727
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x1483
Revision: 0x01
Memory Range: 0xb2400000-0xb2403fff (rw,non-prefetchable)
IRQ: 17 (no events)
Module Alias: “pci:v000014E4d00004727sv0000103Csd00001483bc02sc80i00”
Driver Info #0:
Driver Status: brcm80211 is active
Driver Activation Cmd: “modprobe brcm80211”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #20 (PCI bridge)

Try this
Install Broadcom Drivers from Packman

I have reviewed that site, and have determined that I need the following repository…
Index of /suse/openSUSE_11.4/Essentials/x86_64/
I have also reviewed how to add a repository and the information it provides is incomplete for me to proceed further…
How to add a repo in Terminal
Can you help?

You need this repo
Index of /suse/openSUSE_11.4/

Post result of

uname -a
rpm -qa | grep kernel

You basically are saying I need all the directories one level higher than what I thought. However, I don’t know what you are saying to do (“post result of”?), nor how to add a repo.

Is this what you are asking for? For me to post what shows up after typing in your commands?

Linux linux-mb4w.site #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux


Yes that info is correct

I’m assuming you have a wired connection. You’ll need it to do this.

Lets make sure you have a packman repo (if you have 2 it will not matter so much), so lets add one. Use your mouse to copy and paste the following:

su -
zypper ar -f http://packman.inode.at/suse/openSUSE_11.4/ packman
zypper ref

(a) to accept the signing key if you are asked.

zypper in broadcom-wl broadcom-wl-kmp-desktop

When it’s done
That’s it

Now reboot

I think that’s the same card that I am using in my Dell laptop.

With openSuSE 11.4, I used the broadcom drivers from packman, as has been suggested for you. However, I noticed that when I booted the Gnome 3 live CD, it worked without those drivers.

I have recently been testing the beta releases of 12.1. And I see the same thing. If I install from the KDE live CD, then wifi just works. If I install from the DVD, then it doesn’t work.

So I cheated. I copied the firmware from the KDE live CD, and installed that on my system installed from the DVD. WiFi now works. It turns out to be the contents of directory “/lib/firmware/brcm” on the KDE live system. I booted the live system, and made a tarball of that directory onto a different disk (a usb flash drive would be fine). Then rebooted my installed system, and unpacked the tarball. After that, I rebooted and wireless started working.

Incidently, the content of that directory is:

% ls -l
total 368
-rw-r--r-- 1 root root 269595 Jul  7 20:26 bcm4329-fullmac-4.bin
-rw-r--r-- 1 root root   1604 Jul  7 20:26 bcm4329-fullmac-4.txt
-rw-r--r-- 1 root root  97344 Jul  7 20:26 bcm43xx-0.fw
-rw-r--r-- 1 root root    180 Jul  7 20:26 bcm43xx_hdr-0.fw

I’m pretty sure that you only need the last two of those files (the “.fw” files). The “.txt” file is information. I think the “.bin” file is a Windows driver from which the firmware can be extracted using the “b43-fwcutter” program (which in turn can be installed from the repos).

I hope somebody finds that useful.

My broadcom works in 12.1 without the Packman ‘wl’ driver - BUT
And I stress this. The b43 driver is not providing anything like as good results

When 12.1 is final an I install it. I’ll be switching to ‘wl’ as my bench tests have shown it to stream on average 6 times faster.

Maybe I don’t know what I’m doing. But that’s how it is in my case.

Very interesting. Thanks.

Thank you. It is working now.

Thanks for letting us know