Wireless works without encryption but not with WPA2 personal

I am running XP3 dual boot with openSUSE 11.0. XP connects to my present set up whilst SUSE sees the network but dosen’t accept the password. Without encryption everything is O.K.

Adapter is an Atheros Not sure if its configured properly as I am a complete novice to Linux and networks.

An “unlock keyring” network manager applet thingy has turned up out the blue and I have assigned it a password that is the same as my encrypted password

Any straightforward help would be appreciated, especialy as it may save my marriage! Thanks in advance, Alan.

couple of things to check:-

1 ) set up is correct in YaST
2 ) firewall is set correctly
3 ) encryption matches that of the router
4 ) make sure there is no typo’s in the encryption
5 ) correct drivers are being used.

Also, check the stickies at the start of the wireless section, lots of good info there


Thanks for the immediate response, O.K Yast 1st,

Global Options
User controlled with network manager
IPV6: enabled
Hostname To Send: AUTO
Change default route via DHCP: enabled

AR5212 802.11abg NIC DHCP
MAC: 00:0e:9b:7f:e6:cc
Device name wlan0
Started manually
IP address assigned using DHCP

Hostname: linux-srol
Donaim Name:site
Change Hostname via DHCP: enabled
Update DNS data via DHCP: enabled

Nothing in here!

Edit the card,
General Tab
Activate Device: Manually
Firewall Zone: External
Enable Device Control for Non-rootUser via Kinternet:Enabled
MTU:1500(Ethernet,DSL broadband)
Address Tab
Dynamic Address: DHCP enabled
Hardware Tab
Module Name ath5k

Wireless Device Settings
Operating Mode: Managed
ESSID:“As named by myself and correct”
Authentication Mode: WPA-PSK
Key Input Type: Passphrase enabled
Encryption Key:“As named by myself and correct”

Expert Settings
Bit Rate: auto
Use Power Manaement: enabled

Marks out of ten?


Marks out of ten?
hmm a level 6.
1 ) turn of ipv6
2 ) set device to activate at boot
see if that helps


Many thanks Andy,

When I change the settings you mention, I click finish to configure, and first of all the wired ethernet connection drops, then I get, and have always had this error:

Download Failed:

Download (Curl) error for ‘http://madwifi.org/suse/11.0/repodata/repomd.xml’: Error code:Connection failed

Error message: Couldn’t resolve host ‘madwifi.org’. I then press O.K, re connect wired connection, ask config to re try, which it then quickly finishes.

Re boot check IPV6 and Boot entries - OK

Try wireless connection and no joy. Incidentally when I hover over my named network icon, one called

Auto “my network” and one underneath called System “my network” (wlan0).

Besides WPA, I also have wireless MAC filter.

Any thoughts?


Ahhh, the mac filter, have you added the devices mac to the router ? that will stop any connections dead if you haven’t. Also, have you tried changing channels ? interference can also cause no/bad connections


Andy, by “the device” I presume you mean the machine that has the problem. That is my Laptop (IBM R51 2887 M2G)

Its MAC address, which I obtained through Windows is listed in the routers configuration. The router is a Lynksys WRT 54GL.I assume that address in SUSE is the same as is in windows?. I have not tried changing channels yet, (channel 11-2.462g/hz) but will if you insist.

Dont forget windows picks the connection up immediately on that channel and so did SUSE untill I made the encryption.What channel should I try? is it a case of trying different ones untill success.

Cheers, Alan.

Off the top of my head, i can’t remember which channels interfere, i & lwfinger have posted about the different channels, so a search wouldn’t go amiss there :wink: If the mac address is already there, i’d check for typo’s & matching encryption method.


deltaflyer44 wrote:
> Off the top of my head, i can’t remember which channels interfere, i &
> lwfinger have posted about the different channels, so a search wouldn’t
> go amiss there :wink: If the mac address is already there, i’d check for
> typo’s & matching encryption method.

A given channel n interferes with the range n-2 to n+2. If you do the
math, the only non-interfering choices are 1, 6, and 11. You also ahve
to consider all the other sources of 2.4 GHz emissions.

I use WPA personal, but not WPA and I cannot tell you what gotchas to
look for. One thing is to check for a process running wpa_supplicant
when trying to authenticate.


Dear Larry & Andy, thanks ever so much for your kind input.

I have now solved the problem, but am sadly under divorce proceedings :slight_smile:

The issue was simply that in the configuration options of the router, I had the option of which wireless network mode to choose. The options being Mixed,B Only or,G Only.Thinking G Only would be slightly safer, thats what I did.

As explained previously, Windows had no problem with this but SUSE would only accept the Mixed option.I have kept the wireless channel at no’ 11 - 2.462ghz.

Why this should be is beyond me? I’m off to the pub.


Well, at least your wireless is now working. Now enjoy :slight_smile: