Wireless works with WPA but not WPA2 (OpenSUSE 13.2)

After installing **OpenSUSE 13.2 ** with **KDE 4.14.2

Wifi works only with WPA and not WPA2 security setting on the router** (Netgear WNR612v3)

The wpa_supplicant.log yields the following when trying to connect to router with WPA2 security;

*WPA: 4-way handshake failed - pre-shared key may be incorrect
CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid=‘NETGEARxx’ auth_failures=1 duration=10 reason=WRONG_KEY

Yet when I switch the router to WPA security with the same password the connection is successful.*
WPA: Key negotiation completed with xx:xx:xx:xx:xx:xx [PTK=TKIP GTK=TKIP]

Viewing the connection details via the NetworkManager the ‘wireless security’ tab is set to ‘WPA & WPA2 Personal’

Resolved lol!

  1. Create a file in /etc/modprobe.b to run at boot

sudo touch /etc/modprobe.d/50-iwlwifi.conf

  1. Edit the file to contain the lines

options iwlwifi 11n_disable=1
options iwlwifi bt_coex_active=0

Seems the problem is related to Intel wireless adapters. In this case

Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak]