Wireless works with KDE but not Gnome?

Hi, I’ve recently installed OpenSuse 11.1 with KDE4 and Gnome 2 (the ones that come with the 11.1 download dvd). I’ve managed to set up the KDE desktop to connect to my home network (WPA encrypted), but Gnome isn’t working.
Here’s the problem:
On the Gnome desktop, i type in my encryption key, and hit apply. However, Gnome makes no attempt to connect and when i try to edit the connection settings, it’s erased the key! I’ve tried deleting and re-creating the connection, rebooting, logging in as the root, and nothing has worked.
The network does work, I managed to connect to a non-encrypted network at school, and like I said KDE connects perfectly fine with both networks.
FYI, it’s a Toshiba Satellite-L355D laptop, with an Atheros 802.11 (i think .b?) network card.
Please help!

I suggest you to update your installation. In gnome-terminal type:

sudo zypper refresh
sudo zypper up

For me it’s working correctly. It should be resolved by the update.
Hope that helps.

no, it didn’t work. it still isn’t remembering the key. Is there a way to connect through some other utility other than the network manager? or to run the kde one with gnome?

You can start the KDE network manager in Gnome - if you have the applet installed because the widget won’t work.
To change your setup from Network Manager to ifup:
In YaST go to Network Devices > Network Settings and at the Global options panel change the Network Setup Method to Traditional Method with ifup. In the Overview panel configure your card.