Wireless Works to Dlink Router Not To Internet

When I open 192.168.0.1 from Firefox it connects to my dlink router.
No matter how I enter the parm it gives me unknown host every time
I Tried
sudo /sbin/route add route gw 192.168.0.1
gw:192.168.0.1
gw.192.168.0.1

Yet I can successfully ping 192.168.0.1

Is there a switch that will display current route addresses?

On 08/07/2011 09:46 AM, KentSzabo wrote:
>
> When I open 192.168.0.1 from Firefox it connects to my dlink router.
> No matter how I enter the parm it gives me unknown host every time
> I Tried
> sudo /sbin/route add route gw 192.168.0.1
> gw:192.168.0.1
> gw.192.168.0.1
>
> Yet I can successfully ping 192.168.0.1

Please go back and look at my post. The command is


sudo /sbin/route add default gw 192.168.0.1

It is NOT “route add route”, but “route add default”. The route utility knows it
is adding routes, but you have to tell it this is to be the default.

Whenever someone devotes some effort to helping you, the least you can do is get
the commands right.

You were correct I had omitted the default keyword, it took it now with no errors.
I have rebooted and the /etc.resolv.conf file has
gateway 192.168.0.1 and dns of
nameserver.8.8.8.8 and
nameserver.8.8.4.4

and the /etc/resolv.conf.netconfig has in it at the bottom
search gateway.wildblue.com
nameserver 192.168.0.1

Ping 8.8.8.8
Network Unreachable

Pinging 192.168.0.1
returns valid pings.

Firefox can not find ATT.NET - Email, News, Sports, Entertainment and Games
but does connect to 192.168.0.1 which is the dlink router through wireless.

The /etc/resolv.conf.netconfig gets changed at boot to:
search gateway.2wire.net wildblue.com
nameserver 192.168.0.1

This 2Wire.net was my old modem/router when I had Qwest ISP.

I am presently searching for Content containing text 2wire.net in all files & folders

On 08/07/2011 12:56 PM, KentSzabo wrote:
>
> The /etc/resolv.conf.netconfig gets changed at boot to:
> search gateway.2wire.net wildblue.com
> nameserver 192.168.0.1
>
>
> This 2Wire.net was my old modem/router when I had Qwest ISP.

The search option does not matter much. You will need to reenter the route
command after each boot unti we figure out why routine does not work. The real
question is does it work after that command?

Below are the DLINK Router logs from last two boots.

Priority Time Message
debug Aug 7 12:12:58 UDHCPD sending ACK to 192.168.0.102
info Aug 7 12:12:58 UDHCPD sending OFFER of 192.168.0.102
debug Aug 7 12:12:58 UDHCPD sendOffer : client is in lease/offered table
info Aug 7 12:12:58 UDHCPD sendOffer : device_lan_ip=192.168.0.1 , device_lan_subnet_mask=255.255.255.0
info Aug 7 12:12:54 UDHCPD sending OFFER of 192.168.0.102
debug Aug 7 12:12:51 UDHCPD sendOffer : find a free IP
info Aug 7 12:11:13 [244300.290000] module arch cleanup sch_ubicom_streamengine: OCM instruction memory free of 0 @00000000
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered EXEC SCANNER DISCONNECT
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered EXEC SCANNER CONNECT
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered GET USB_DEVICE_LIST
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered GET SCANNER_STATUS
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered GET SCANNER PORT_NAME
debug Aug 7 12:10:36 [244263.410000] jcp_command_register: new command registered GET USB_PORT_NAME
debug Aug 7 12:10:36 [244263.320000] jcpcore: start
info Aug 7 12:10:36 [244263.250000] usbcore: registered new interface driver sxuptp_driver
debug Aug 7 12:10:36 [244263.170000] sxuptp: sxuptp_keepalive_thread start
info Aug 7 12:10:34 read /etc/hosts - 2 addresses
info Aug 7 12:10:34 using nameserver 204.194.232.200#53
info Aug 7 12:10:34 using nameserver 204.194.234.200#53
info Aug 7 12:10:34 reading /etc/resolv.conf
info Aug 7 12:10:34 compile time options: IPv6 GNU-getopt no-MMU ISC-leasefile no-DOCTOR no-NOWILD no-DBus no-I18N TFTP
info Aug 7 12:10:34 started, version 2.45 cachesize 150
notice Aug 7 12:10:33 HTTP listening on port 65535
info Aug 7 12:10:31 [244258.380000] module arch cleanup nf_conntrack_ftp: OCM instruction memory free of 0 @00000000
info Aug 7 12:10:31 [244258.240000] module arch cleanup nf_nat_ftp: OCM instruction memory free of 0 @00000000
info Aug 7 12:10:30 [244257.610000] module arch cleanup sxuptp: OCM instruction memory free of 0 @00000000
debug Aug 7 12:10:30 [244257.610000] sxuptp: sxuptp_keepalive_thread stop -512]
info Aug 7 12:10:30 [244257.470000] module arch cleanup sxuptp_driver: OCM instruction memory free of 0 @00000000
info Aug 7 12:10:30 [244257.470000] usbcore: deregistering interface driver sxuptp_driver
info Aug 7 12:10:30 [244257.330000] module arch cleanup jcp: OCM instruction memory free of 0 @00000000
debug Aug 7 12:10:30 [244257.330000] jcpcore: stop -512]
debug Aug 7 12:10:30 [244257.330000] jcpcore: jcpcore_recv -512]
info Aug 7 12:10:30 [244257.200000] module arch cleanup jcp_cmd: OCM instruction memory free of 0 @00000000
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered EXEC SCANNER DISCONNECT
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered EXEC SCANNER CONNECT
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered GET USB_DEVICE_LIST
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered GET SCANNER_STATUS
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered GET SCANNER PORT_NAME
debug Aug 7 12:10:30 [244257.200000] jcp_command_unregister: command unregistered GET USB_PORT_NAME
info Aug 7 12:10:29 [244256.960000] br0: port 2(ath0) entering forwarding state
info Aug 7 12:10:29 [244256.960000] br0: topology change detected, propagating
info Aug 7 12:10:29 exiting on receipt of SIGTERM
notice Aug 7 12:10:29 received signal 15, good-bye
info Aug 7 12:10:29 [244256.590000] flags=0
info Aug 7 12:10:29 [244256.590000] ioctl eth0, 35312
info Aug 7 12:10:28 [244255.960000] br0: port 2(ath0) entering learning state
debug Aug 7 12:10:28 dhcpc sent restart signal to rc
debug Aug 7 12:10:28 dhcpc is waiting for rc to be idle.
info Aug 7 12:10:26 [244253.770000] br0: port 2(ath0) entering disabled state
info Aug 7 12:10:26 [244253.680000] Enable bridge netfilter (erno = 0)

I just cleared the logs and rebooted here is a shorter version:

Priority Time Message
debug Aug 7 12:29:01 UDHCPD sending ACK to 192.168.0.102
info Aug 7 12:29:01 UDHCPD sending OFFER of 192.168.0.102
debug Aug 7 12:29:01 UDHCPD sendOffer : client is in lease/offered table
info Aug 7 12:29:01 UDHCPD sendOffer : device_lan_ip=192.168.0.1 , device_lan_subnet_mask=255.255.255.0
info Aug 7 12:27:33 Log cleared by Administrator
info Aug 7 12:27:33 Log init

Helpful Hints…

I searched the DLink pages for th .102 ip address and found my desktop has it.
Number of Dynamic DHCP Clients : 1
Hardware Address Assigned IP Hostname Expires
00:13:02:36:5f:c6 192.168.0.102 linux-mkra Sun Aug 14 12:29:01 2011 Revoke Reserve

Check the log frequently to detect unauthorized network usage.

You can also have the log mailed to you periodically. Refer to Tools → EMail.

More…

I don’t see anything wrong there. After you enter the default route command,
which of the commands below work?


ping -c 5 192.168.0.1
ping -c 5 8.8.8.8
ping -c 5 www.samba.org

ping -c 5 192.168.0.1
64 bytes from 192.168.0.1: icmp_req=1 time=1.69 ms
64 bytes from 192.168.0.1: icmp_req=2 time=0.765 ms
64 bytes from 192.168.0.1: icmp_req=3 time=0.781 ms
64 bytes from 192.168.0.1: icmp_req=4 time=0.768 ms
64 bytes from 192.168.0.1: icmp_req=5 time=0.727 ms

ping -c 5 8.8.8.8
connect: Network is unreachable
ping -c 5 Samba - opening windows to a wider world
ping: unknown host Samba - opening windows to a wider world

I am using my lan connected desktop to post results that is resolving “www.samba.org

On 08/07/2011 01:46 PM, KentSzabo wrote:
>
> I just cleared the logs and rebooted here is a shorter version:
>
> Priority Time Message
> debug Aug 7 12:29:01 UDHCPD sending ACK to 192.168.0.102
> info Aug 7 12:29:01 UDHCPD sending OFFER of 192.168.0.102
> debug Aug 7 12:29:01 UDHCPD sendOffer : client is in lease/offered
> table
> info Aug 7 12:29:01 UDHCPD sendOffer : device_lan_ip=192.168.0.1 ,
> device_lan_subnet_mask=255.255.255.0
> info Aug 7 12:27:33 Log cleared by Administrator
> info Aug 7 12:27:33 Log init

The problem is NOT on the router. It is providing an IP address with DHCP. That
is all it needs to do. I don’t need to see those logs. Your computer knows how
to route to 192.168.0.X, but does not know how to get to the wide world.

On your computer enter the following:


sudo /sbin/route add default gw 192.168.0.1
/sbin/route -n

Post those outputs, and try the 2nd and 3rd pings.

Ping -c 5 8.8.8.8 works and the ping to Samba - opening windows to a wider world also works and returns 5 valid messages.

Being this worked I tried Firefox connecting to Yahoo! and it also works now. How do I make this permanent?

On 08/07/2011 03:36 PM, KentSzabo wrote:
>
> Ping -c 5 8.8.8.8 works and the ping to ‘Samba - opening windows to a
> wider world’ (http://www.samba.org) also works and returns 5 valid
> messages.
>
> Being this worke I tried Firefox connecting to ‘Yahoo!’
> (http://www.yahoo.com) abd it also works now. How do I make this
> permanent?

I have had this happen to me on a temporary basis, but never have it be
permanent. Normally one could add the line to file /etc/init.d/after.local;
however, wireless is not started until you log in, which is after that file is
executed. As a result, we need a little more creativity.

Log in as root using “su -” from a terminal. In root’s home directory (/root),
create a file named fix_routing that contains the following:

#!/bin/sh
sleep 30
/sbin/route add default gw 192.168.0.1

After you create the file, make it executable with “chmod a+x fix_routing”. Now
edit /etc/init.d/after.local and add a line that says “/root/fix_routing &”.

To explain a bit, the & in the command says to run the script fix_routing in the
background. If you forget that, your system will hang for 30 seconds. I guessed
at how long the sleep should be. If you find that routing is not ready, you can
change it to 40, etc.

Yep this works as I rebooted and tried the pind -c 5 8.8.8.8 which failed
issued the /sbin/route add default gw 192.168.0.1
tried the ping again and it worked.
There must be some configuration file that is using the old 2wire.net as a gateway, I am searching all for it. I see the resolv.conf picked up the 2wire.net again, so something is setting it at boot time.

From my searching I see that /etc/sysconfig/network/config has a statement in it containing
NETCONFIG_DNS_STATIC_SEARCHLIST=‘gateway.2wire.net

Suse has an article about it see URL
Configure Netconfig for Static Domain Search Lists | Novell User Communities

Have you ever used the netconfig command? I am reading the man 8 netconfig pages?