Wireless works on Live Session, stops working once installed

I’m a little embarassed about asking this, because I suspect I’m overlooking something obvious.

I just installed OpenSuse 11.2 using a Live Session CD (KDE) on a computer that can only access internet via a USB Wireless adapter. During the Live Session the internet worked without problems once I gave the password to the network (WEP), I even surfed during the installation.

Now, with the system installed I can’t make the wireless work. I don’t know what could be that different from the Live Session, I don’t really know much about networks and I’m stumped. I booted using the LiveCD and wireless worked but as soon as I boot from hard drive, it’s a no go.

Any help on what I’m doing wrong would be much appreciated.

On 01/02/2010 07:36 PM, papinatrix wrote:
>
> I’m a little embarassed about asking this, because I suspect I’m
> overlooking something obvious.
>
> I just installed OpenSuse 11.2 using a Live Session CD (KDE) on a
> computer that can only access internet via a USB Wireless adapter.
> During the Live Session the internet worked without problems once I gave
> the password to the network (WEP), I even surfed during the
> installation.
>
> Now, with the system installed I can’t make the wireless work. I don’t
> know what could be that different from the Live Session, I don’t really
> know much about networks and I’m stumped. I booted using the LiveCD and
> wireless worked but as soon as I boot from hard drive, it’s a no go.
>
> Any help on what I’m doing wrong would be much appreciated.

Please post the output of ‘/sbin/route -n’ and ‘cat /etc/resolv.conf’.

I ran those on console and it told me that such file or directory didn’t exist.

On 01/02/2010 09:06 PM, papinatrix wrote:
>
> I ran those on console and it told me that such file or directory didn’t
> exist.

Then you mistyped them. Once again

/sbin/route -n
cat /etc/resolv.conf

Oh, boy, do I feel silly.

Here’s the proper output:

For
/sbin/route -n

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0

For
**cat /etc/resolv.conf
**

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

On 01/03/2010 01:26 PM, papinatrix wrote:
>
> Oh, boy, do I feel silly.
>
> Here’s the proper output:
>
> For
> /SBIN/ROUTE -N
>
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0
> wlan0

You have a problem with your routing. The network system knows how to get to the
192.168.1.0/24 subnet, but not the world.

If you are using a static IP, then you have a configuration problem. If you are
using DHCP, you are impacted by a bug that has been fixed but you have probably
not gotted the updates.

Run the command

sudo /sbin/route add default gw 192.168.1.1

That will add the necessary routing. Look at ‘/sbin/route -n’ afterward.

If you still cannot get network access, add the line ‘nameserver 8.8.8.8’ to
/etc/resolv.conf. In any case, please do an update ASAP.

This solved the issue. Changed the values as Root and I was able to reach the Internet, update, and now everything is working fine.

Thanks a lot for the help and patience!