Wireless works (in theory) but no sites load

I have recently installed openSuse 11.1 additionally to my Windows XP.
First I could not make the internet run but after playing with the settings I made Linux recognize my W-Lan (Which is Belkin Wireless G+ MIMO USB Adapter).
So now Linux says that I am connected but if I open a browser and try to connect to any site it just loads forever and after a time I get the usual Error of there is no Internet connection.
Also every program which wants to update via Internet cannot do it and that program for adding packages nearly breaks down everytime because it cannot connect.

After I had no reason using Linux without having Internet I would really appreciate your help.
I also apologize if this problem was already solved in this forum but I could not find the same thing with the search function.

So please HELP :’( I need Internet so I am not that dependent on stupid Windows.

As always:

Read the stickies and provide more information.

>_> What do you mean with “read the stickies”

First boot back into linux, then open a terminal (from the main menu, or simply press alt-f2 and type in konsole).

Then in the terminal window, type the following:

su (it will ask for the root password, you should have set this on install, type it in and press enter)

ifconfig (that will give information about your network connections

Now select all the text it throws out with your mouse, right click and copy it. Then form the menu again, look for and open kate (text editor), paste the text into there, save it.

next go back to the terminal and type this:

route (that will give information about your routing)

Do the same again, copy/paste/save.

Then post a reply here and include the text that you saved, not the files, just the text is ok.

And don’t let unhelpful forum members put you off :).

growbag wrote:
> And don’t let unhelpful forum members put you off :).

Was it unhelpful to spend several hours writing “howto’s” and posting them as

Is it unhelpful to expect a new posting to save us time by reading them?

If so, then I will be totally unhelpful and ignore this forum completely!!!

< sigh > Growbag, the stickies were written by wireless devs, re-inventing the wheel is really counter-productive,also, it helps users to help us diagnose the problems and give more tailored answers to users. So,ultimately,upsetting/annoying the devs is really counter-productive after getting them to write such articles


True, but a user with only 2 posts to his name is not going to understand a rather rude RTFM answer now is he?

It is merely offputting, and feeds the myth of Linux unfriendliness.

It would have been more helpful if it had been explained a little clearer.

A lot of people on this forum seem to forget that they were also once new users, is it so hard to extend a little friendliness and understanding?

I know that it can get really annoying continually re-explaining stuff that we all think everybody should know, and yes, if you have already explained it once to a poster and they have ignored it, then fine.

But simply assuming that everybody knows what a “sticky” is when for all you know they have never even used a forum before is not very helpful.

Oh, I remember that time very well.

I used search engines, read fora and tutorials I found myself and was able to solve my problems or at least get enough information to ask the right questions.

But if you want to make it better here, then put your actions where you put your mouth and make it better.

I agree with Akoellh. We should not only support eachother in OS matters, but also in the use of the fora. I estimate that at least 50% of posts should not have been necessary if the writers would not have banged their frustration into the fora right away, but would have searched the fora first instead.
All this is a matter of educating eachother, so just a RTFM cannot do. Fora are not for personal annoyances.

So here it is:

ifconfig returns:

eth0 Link encap:Ethernet HWaddr 00:19:66:49:80:0E
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:220 Base address:0xe000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2840 (2.7 Kb) TX bytes:2840 (2.7 Kb)

wlan0 Link encap:Ethernet HWaddr 00:1C:DF:24:A8:C0
inet addr: Bcast: Mask:
inet6 addr: fe80::21c:dfff:fe24:a8c0/64 Scope:Link
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:53 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1032 (1.0 Kb) TX bytes:7884 (7.6 Kb)

wmaster0 Link encap:UNSPEC HWaddr 00-1C-DF-24-A8-C0-38-63-00-00-00-00-00-00-00-00
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

and route returns:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 2 0 0 wlan0
loopback * U 0 0 0 lo
default UG 0 0 0 wlan0

I am sorry if I unnecessarily opened a new thread but I am new in this forum and it is the first forum I am using. So if I did something wrong you could tell me more friendly so I won’t do it again.

So I hope you can help me with my wireless problem anyways.

that smiley in the wlan0 is : D

OK, now try with these commands:

***ping -c

ping yahoo.com

That will tell you if you can actually talk to your router, and the second one will tell if the DNS system is working.

Please post the results here.

Ok. This is what I get:
linux-00kw:/home/pr0zaxx # ping -c
Usage: ping -LRUbdfnqrvVaA] -c count] -i interval] -w deadline]
-p pattern] -s packetsize] -t ttl] -I interface or address]
-M mtu discovery hint] -S sndbuf]
-T timestamp option ] -Q tos ] [hop1 …] destination

Looks like it just says me what I can do with the ping command right?:frowning:

linux-00kw:/home/pr0zaxx # ping yahoo.com
ping: unknown host yahoo.com

I don’t know if it is important but it tried to connect to yahoo for 20 seconds. That is roughly the same time the browser needs to tell me that it cannot connect to the site.
Which I do not understand because Windows does and Linux says it has a connection and just does not connect to the sites.

Yeah, that’s the way I like it.

Calling me “unhelpful” but posting such crap as “help”.

Perhaps you should RTFM yourself my dear growbag and stop being such a loudmouth.

Needless to say that the sticky, which has been mentionend and linked several times now contains correct syntax for the ping command.

Oops, looks like I missed a part of the command out there, sorry!

The correct command should have been:

ping -c 4

In that case I get the following:

linux-00kw:/home/pr0zaxx # ping -c 4
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable

— ping statistics —
3 packets transmitted, 0 received, +4 errors, 100% packet loss, time 2014ms
, pipe 3

linux-00kw:/home/pr0zaxx # ping yahoo.com
ping: unknown host yahoo.com

Looks like the problem is that Linux cannot connect to my router :(.
So what can I do?

@growback: Thanks for your help so far

Hmm, that’s not good.

Just to clarify, seeing as nobody has actually explained this to you even after you asked, stickies are posts that have been written by forum members.

They are called stickies because they are static and “stick” to the top of the forum pages.

The user lwfinger is incredibly knowledgeable in the wireless department, maybe follow some of his threads that you can find here:

Wireless - openSUSE Forums

It was suggested that this link was provided earlier, but I must be blind or something as I can see no links that were provided to you in this thread.

If that fails, then I would simply search google for the model of your wireless adapter and see what turns up.

I’m no expert, I’m just trying to help out as you seemed rather lost.

But from the info you provided, it seems to me that you are not connecting to the router properly. Are you using the network manager icon to connect, or did you set the network up through the Yast tool?

Good luck :slight_smile:

Internet works now.:slight_smile:
I switched from NetworkManager to YaST and changed some settings.
But I still don’t understand why it did not work with NetworkManager because I have basically the same settings.:stuck_out_tongue:

Thanks for you help anyway.