Wireless works fine on XP, Ubuntu, Suse 11.1, but not for Suse 11.2

On my Acer netbook (AOA-150-1635) the wireless works fine with WinXP, Ubuntu, and used to work with Suse 11.1. I replaced the Suse 11.1 with a clean network install of Suse 11.2. I couldn’t get the wireless to work and did another network install using the wireless. When the install was completed I could not get the wireless to work with Suse 11.2.

When I run the “collectNWData.sh” it shows–

!!! CND0120E: Network card wlan0 has no IP address
wlan0 Interface doesn’t support scanning : Network is down

!!! CND0380E: No WLANs detected on interface wlan0. Hardware and/or driver not configured properly
!!! CND0240E: knetworkmanager for network configuration enabled but a YAST network card configuration for wlan0,eth0 exist

I looked up error CD0120E and changed the network devices setup to “traditional”. The wireless “scan” picked up the routers and I added the encryption keys. Still no joy. I ran “collectNWData.sh” again and it said it is better to use the Network Manager.

!!! CND0180I: The system can’t ping external IP address 195.135.220.3
!!! CND0150E: There might be a problem with the default gateway definition 10.1.1.1 on interface eth0
!!! CND0310W: Classic network configuration with ifup was detected. Configuration with knetworkmanager is much easier
!!! CND0360E: Wireless connection tested with an existing wired connection on interface eth0. Unplug the cable and execute the script again

Going back to Yast, Network Devices, I set Network Manager. The result is that it is back to the beginning with “collectNWData.sh” giving the original error.

On 03/30/2010 08:56 PM, dhaselwood wrote:
>
> On my Acer netbook (AOA-150-1635) the wireless works fine with WinXP,
> Ubuntu, and used to work with Suse 11.1. I replaced the Suse 11.1 with
> a clean network install of Suse 11.2. I couldn’t get the wireless to
> work and did another network install -using the wireless-. When the
> install was completed I could not get the wireless to work with Suse
> 11.2.
>
> When I run the “collectNWData.sh” it shows–
>
> !!! CND0120E: Network card wlan0 has no IP address
> wlan0 Interface doesn’t support scanning : Network is down
>
> !!! CND0380E: No WLANs detected on interface wlan0. Hardware and/or
> driver not configured properly
> !!! CND0240E: knetworkmanager for network configuration enabled but a
> YAST network card configuration for wlan0,eth0 exist
>
> I looked up error CD0120E and changed the network devices setup to
> “traditional”. The wireless “scan” picked up the routers and I added
> the encryption keys. Still no joy. I ran “collectNWData.sh” again and
> it said it is better to use the Network Manager.
>
> !!! CND0180I: The system can’t ping external IP address 195.135.220.3
> !!! CND0150E: There might be a problem with the default gateway
> definition 10.1.1.1 on interface eth0
> !!! CND0310W: Classic network configuration with ifup was detected.
> Configuration with knetworkmanager is much easier
> !!! CND0360E: Wireless connection tested with an existing wired
> connection on interface eth0. Unplug the cable and execute the script
> again
>
> Going back to Yast, Network Devices, I set Network Manager. The result
> is that it is back to the beginning with “collectNWData.sh” giving the
> original error.

Please post the entire output of the script. It is designed to tell us
the maximum information about your system.

What we need is the result of

/sbin/lspci -nnk

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
Kernel driver in use: pcieport-driver
00:1c.3 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 [8086:27d6] (rev 02)
Kernel driver in use: pcieport-driver
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: i801_smbus
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: Acer Incorporated [ALI] Device [1025:015b]
Kernel driver in use: r8169
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
Subsystem: Foxconn International, Inc. Device [105b:e008]
Kernel driver in use: ath5k

ath5k is the driver the network installer used.

03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001  Wireless Network Adapter [168c:001c] (rev 01)
        Subsystem: Foxconn International, Inc. Device [105b:e008]
        Kernel driver in use: ath5k

I should wait and see what @lwfinger has to say. Once you have supplied as he asks.

This should have the .txt output of collectNWData.sh–
nopaste.info - free nopaste script and service

On 03/30/2010 10:46 PM, dhaselwood wrote:
>
> This should have the .txt output of collectNWData.sh–
> ‘nopaste.info - free nopaste script and service’
> (http://nopaste.info/90f3181a96.html)

Please read line 14 of the script output. You cannot get a valid test of
the wireless system if the wired cable is connected.

And the other ones should be read carefully, too.

The script caught all user’s configuration errors and pointed to detailed instructions on how to solve these problems.

That’s what it was written for, so take advantage of it.

Maybe I wasn’t clear on my early posts. I did follow the error code correction suggestions and they didn’t work.

The following paste is a result of setting back to Network Manager, and going in to Managing Connections and setting a static IP address,SSID, encryption key, and running the script to remove the eth0 and wlan0 configurations as an earlier error code suggested–

nopaste.info - free nopaste script and service

You cannot get a valid test of
the wireless system if the wired cable is connected.
When I go into Yast and set traditional and set a static IP for the wireless, plus SSID and encryption, ‘collectNWData.sh’ shows the ethernet cable plugged in even though it was physically disconnected.

On 03/31/2010 02:26 PM, dhaselwood wrote:
> wireless, plus SSID and encryption, ‘collectNWData.sh’ shows the
> ethernet cable plugged in even though it was physically disconnected.

Random mucking around trying everything has its consequences. You have
created a configuration file for eth0 with bad info in it. Please do the
following:

kdesu xedit /etc/sysconfig/network/ifcfg-eth0

Find the line with “STARTMODE” and change whatever is there to ifplugd.
Once you do that and save the file, it should work.

Thanks for the assistance.

kdesu xedit /etc/sysconfig/network/ifcfg-eth0

This did not fix the problem. Here were the steps–

  1. There was no ifcfg-eth0 file, there was ‘old.ifcfg-eth0’ (as well as ‘old.ifcfg-wlan0’ so I made a copy ‘ifcfg-eth0’
  2. I changed STARTMODE from ‘auto’ to ‘ifplugd’.
  3. It didn’t work, so I rebooted…no success.

I started over with a new, clean install of 11.2 (network).

After the install completed I ran ‘iwlist scan’. The output for wlan0 showed all the APs in the vicinity. Looks promising!

“Enable wireless” in Network Manager was greyed out, and Managing Connections, Wireless, scan, produced no results.

I then ran the online software update. IIRC one of the updates had to do with Network Manager. After that completed, and rebooting. ‘iwlist scan’ says, “Interface doesn’t support scanning : Network is down”.

I then made the change to /etc/sysconfig/network/ifcfg-eth0, changing ‘auto’ to ‘ifplugd’ and rebooting. iwlist scan says wlan0 doesn’t support scanning, etc.

Is the update the cause problem?

would it be very irksome to suggest to you to run the diagnostic script again?

Benutzeranleitung/Usersguide von/of collectNWData | collectNWData.sh

it may well give some answers; it would certainly give detail for a wireless expert to comment on;

if you find it unhelpful, that too would be of use to framp who follows this forum, and is the author of the script; he would be delighted for you to give him feedback on his script;

OK, the following is the result of running collectNWData.sh with the current situation–
nopaste.info - free nopaste script and service
The wireless is currently working correctly under “traditional” Network Settings configuring. I retrained the DHCP, and the router correctly assigned an IP address, but the DNS server and gateway IP had to be assigned manually. (Earlier when I tried this I used a static IP (which of course requires entering a DNS server and gateway IP–it didn’t work, but I haven’t tried to duplicate it. Having to enter the DNS server and gateway IP was a surprise when DHCP was enabled.)

In traditional, setup the scan works fine, but with Network Manager scan does not work (and appears nothing else as well).
lwlist scan shows the following (again in this “sort-of-working” traditional mode)–
deh@Acer:~/Download> /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:21:63:E7:D0:62
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=35/70 Signal level=-75 dBm
Encryption key:on
ESSID:“VUNBF”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000f0dddb7a2
Extra: Last beacon: 1194964ms ago
IE: Unknown: 000556554E4246
IE: Unknown: 010882848B0C12961824
IE: Unknown: 030106
IE: Unknown: 2A0100
IE: Unknown: 32043048606C

deh@Acer:~/Download>

I’ll switch to Network Manager and post the results (which unless luck is involved, will show errors), but the post will be in a couple hours as I have to break.

On 04/02/2010 04:46 PM, dhaselwood wrote:
>
> OK, the following is the result of running collectNWData.sh with the
> current situation–
> ‘nopaste.info - free nopaste script and service’
> (http://nopaste.info/df3cc2c6aa.html)
> The wireless is currently working correctly under “traditional” Network
> Settings configuring. I retrained the DHCP, and the router correctly
> assigned an IP address, but the DNS server and gateway IP had to be
> assigned manually. (Earlier when I tried this I used a static IP (which
> of course requires entering a DNS server and gateway IP–it didn’t work,
> but I haven’t tried to duplicate it. Having to enter the DNS server and
> gateway IP was a surprise when DHCP was enabled.)
>
> In traditional, setup the scan works fine, but with Network Manager
> scan does not work (and appears nothing else as well).
> lwlist scan shows the following (again in this “sort-of-working”
> traditional mode)–
> deh@Acer:~/Download> /usr/sbin/iwlist scan

When you run iwlist as an ordinary useer, you get a passive scan. To
really see what AP;s are around, use ‘sudo /usr/sbin/iwlist scan’.

When you run iwlist as an ordinary useer, you get a passive scan. To
really see what AP;s are around, use ‘sudo /usr/sbin/iwlist scan’.
I get exactly the same thing running iwlist scan running as ‘su’, ‘sudo /usr/sbin/’, and user’ /usr/sbin/’, namely –

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Interface doesn’t support scanning : Network is down

The following are the steps I’ve taken to switch from the “sort of working” tradtional configuration to Network Manager–

  1. Network Settings: select Network Manager
  2. With ethernet cable unplugged no network connection; no Network Manager icon
  3. Reboot: Network Manager icon now present. “Enable wireless” greyed out; “Manage Connections” black.
  4. Select Manage Connections. Click on 'ss tab (partially hidden wireless tab). Select “New Wireless Connection never used” and click Edit.
  5. KDE wallet comes up. Enter password
  6. SSID of router is showing. Click on “scan”. Scan window comes up and nothing happens. Click OK. SSID now has gone blank. Re-enter SSID.
  7. Try ping of router, i.e. 192.168.1.1 Response: network unreachable.
  8. Try iwlist. Response: Network is down. Run collectNWData.sh.
    Run. Response: 1st error: no IP address.
    nopaste.info - free nopaste script and service
  9. Select manual for ip address. Enter router IP, netmask 255.255.255.0, gateway 192.168.1.1, DNS server 4.2.2.5; enter, OK.
  10. Rerun (after saving collectNWData.txt to …txt.1). Same errors as before.
    nopaste.info - free nopaste script and service
    Note that the error that the IP address is not set is still there even though it was set manually,

When it comes to using Network Manager, it appears that settings entered into Network Manager do not do anything as collectNWData.sh gives the same error regardless of what is entered in Network Manager.

BTW, I tried duplicating the Network Manager failure after the software update to a clean installation (where iwlist showed everything working correctly after the install completed, but failed with ‘network down’ after the software updates (which included the one to Network Manager). When I did (yet another!) clean install the failure was immediate. Thinking back, before I did the clean re-install, I did a clean re-install with gnome and had wireless trouble, so I did a clean re-install back with kde, My attempt to duplicate the temporary success with iwlist scan skipped the intervening install with gnome, and if the issue has to do with uninitialized static variables, then there is the possibility of different “junk” was present.