Wireless working but no internet connection

I installed openSUSE 12.3 with GNOME. At first i had problems with my wireless card (a Broadcom BCM4313), but then i installed the correct drivers and it all worked fine on my home wifi.

Now i’ve come back to university: the university wireless network is detected and network manager says i’m connected to it (authenticated and stuff), but when i open firefox it says there’s no internet connection and it can’t reach google. I’m sure the network is working fine since i’m writing this from my Win7 partition (and i have made no login mistakes).

To be more precise: the university has 2 different networks. One is secured (login at connection) and the other is open (browser login access). I manage to connect to the secure one (but still no internet access), while when connecting to the open one it just says it cannot connect.

Security for the secure is of type WPA2-Enterprise with AES cryptography, and with Win7 i authenticate with Microsoft: PEAP method (that’s what i get from the wifi properties on Win7).

Tried to disable the firewall to see if was stupid but it didn’t change anything. What could i do?

Since i’m quite new to linux i would ask to be as clear as possible in the answers.

Thank you.

What Firefox shows is only a symptom.

You check if you have Internet connection by pinging a system on the Internet. E.g.:

ping -c1

So please check this first.

And when it shows that it can ping to the system, you have Internet connection. Though it might be that you have no proper DNS server configured and thus using host/domain names does not “work” because they are not resolved to IP addresses. You can check that e.g. with:

nslookup forums.opensuse.org