wireless wont get valid IP

This is bizarre. No matter what I do, I get a 169.254.x.x IP
Here is networkmanagers log;

pr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Activation (wlan0/wireless): connection 'Jon' has security, and secrets exist.  No new secrets needed.
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Config: added 'ssid' value 'Jon'
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Config: added 'scan_ssid' value '1'
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Config: added 'psk' value '<omitted>'
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> Config: set interface ap_scan to 1
Apr 24 02:47:09 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  scanning -> associating
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  associating -> associated
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  associated -> 4-way handshake
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  4-way handshake -> group handshake
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): supplicant connection state:  group handshake -> completed
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'Jon'.
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): device state change: 5 -> 7 (reason 0)
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> dhclient started with pid 5674
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Apr 24 02:47:12 linux-37mz NetworkManager[3207]: <info> (wlan0): DHCPv4 state changed nbi -> preinit
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <warn> (wlan0): DHCPv4 request timed out.
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 5674
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Timeout) scheduled...
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Timeout) started...
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> (wlan0): device state change: 7 -> 9 (reason 5)
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <warn> Activation (wlan0) failed for access point (Jon)
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> Marking connection 'Jon' invalid.
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <warn> Activation (wlan0) failed.
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Timeout) complete.
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> (wlan0): device state change: 9 -> 3 (reason 0)
Apr 24 02:47:58 linux-37mz NetworkManager[3207]: <info> (wlan0): deactivating device (reason: 0).

I’d paste wicd’s log but its very similar.

wpa_supplicant log looks like;

No network configuration found for the current AP
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0
No network configuration found for the current AP
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0
No network configuration found for the current AP
CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0

and just keeps repeating that.

my wpa_supplicant.conf looks like this;

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=0
#update_config=1
network={
   ssid="Jon"
   psk="**********"
   proto=WPA2
   key_mgmt=WPA-PSK
   pairwise=TKIP
   group=CCMP TKIP
   priority=5 
   wpa_ptk_rekey=600
}

lsmod shows iwlcore and iwlagn
lspci shows 02:00.0 Network controller: Intel Corporation WiFi Link 5100
dmesg

194087.841725] wlan0: authenticate with 00:25:9c:c8:cf:76 (try 1)
[194087.844521] wlan0: authenticated
[194087.844560] wlan0: associate with 00:25:9c:c8:cf:76 (try 1)
[194087.846891] wlan0: RX AssocResp from 00:25:9c:c8:cf:76 (capab=0x411 status=0 aid=3)
[194087.846895] wlan0: associated
[194096.827175] martian source 169.254.124.148 from 169.254.124.148, on dev eth0
[194096.827180] ll header: ff:ff:ff:ff:ff:ff:00:16:ea:71:94:dc:08:06
[194097.027315] martian source 169.254.124.148 from 169.254.124.148, on dev eth0
[194097.027319] ll header: ff:ff:ff:ff:ff:ff:00:16:ea:71:94:dc:08:06
[194127.873332] martian source 169.254.124.148 from 169.254.124.148, on dev eth0
[194127.873338] ll header: ff:ff:ff:ff:ff:ff:00:16:ea:71:94:dc:08:06
[194128.073651] martian source 169.254.124.148 from 169.254.124.148, on dev eth0
[194128.073657] ll header: ff:ff:ff:ff:ff:ff:00:16:ea:71:94:dc:08:06
[194133.635343] wlan0: deauthenticating from 00:25:9c:c8:cf:76 by local choice (reason=3)
[194133.655163] cfg80211: Calling CRDA to update world regulatory domain
[194133.660161] cfg80211: World regulatory domain updated:
[194133.660165]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[194133.660168]     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[194133.660170]     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[194133.660173]     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[194133.660175]     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[194133.660229]     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

which brings us right back to the logs.

Please don’t suggest wicd or traditional ifup wlan0, right now they don’t even work for wireless

Do you have network-manager installed? According to another thread it may be interfering and removing it may fix your issue.
Although personally, I would use network-manager instead of a manual config.

Another suggestion is disabling ipv6.

Yes, I have networkmanager installed. I have also tried with out networkmanager, that is to uninstall it, still the same problem.

I have seen this happen on one of my systems. However, when that happened, it also happened if I booted to Windows. Restarting the router fixed it.

That might not be what you are seeing. I’m mentioning just as a reminder that there can be multiple possible causes of such a problem.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Fun command for testing. Assuming your wireless NIC is ‘wlan0’:

sudo /usr/sbin/dhcpcd-test wlan0

Post the output here, please.

Good luck.

On 04/24/2011 01:36 PM, Jonathan R wrote:
>
> rodhuffaker;2329028 Wrote:
>> Do you have network-manager installed? According to another thread it
>> may be interfering and removing it may fix your issue.
>> Although personally, I would use network-manager instead of a manual
>> config.
> Yes, I have networkmanager installed. I have also tried with out
> networkmanager, that is to uninstall it, still the same problem.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNtKbxAAoJEF+XTK08PnB5SPYP/ieykwoSjo1H9rm9kPGS3Z5J
MmyzQYt5YdJq+R+dNv24eSSeD7Vet4KvwGFcPrCk/rGLgDvfPQmGG8HRnNRjXAu5
FVdUMgQ1VeU3vUNoeADegYI1WbOzDWrRUqYMrf3M7FWitFe5aiq+XZ7sNfNK14ug
2PcFTyJQ5h7io6+gWHHu8GvashFPishw9EczQwxWrji6VC5RTZhW/xcJ4RLLYMrG
prpPFnbO/B2i6DE1p5zdT1EHemWFfv6TS0oCM+AnT/yJazwaY5PuNC8wPKgrWIeq
q+LMCQs4wksH4OPgqsR0JZl/gjTGrDsXVADlP0vhbNOezopID+9u3Ul3jD355/I9
ji41dm8utol9yAYnJTdiKvIYLPaphKIjWWmmFG0atCXAUIVbQoTNhKYOCvvUmgNz
/UxPL8Qi0OUJ52wwB/lPg0/fZ+rNujYwuSBSjsbXI/6YPKMg1uYvsocUZrtATMUR
v+nmnmSMuJmMEnbScxS26mOciIpWRrxmov+DUCSUQ/wg45RAtCx/L0TBn8frxgZk
WUcjwbHDpic+yMlCpm+Ufsd3Oy+HjnDajMllmD3caBBESeKPUdjhGqwFcz2QGrkW
JdRnltLL/2cVhLo++k6IVjyt0h2vGoqbQgO5c+vusdQBQVa45kLhtGZCfs8VZnbR
xMa7EzmzF9ixTr1o/DeR
=KXGl
-----END PGP SIGNATURE-----

Here are the results;

/usr/sbin/dhcpcd-test wlan0
info, wlan0: hardware address = 00:16:ea:71:94:dc
info, wlan0: broadcasting for a lease
debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
debug, wlan0: waiting for 10 seconds
debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
err, wlan0: timed out
info, wlan0: exiting

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Your DHCP server isn’t responding (see the timed out) to your machine’s
request for information. Fix that and all will be well.

Good luck.

On 04/24/2011 09:06 PM, Jonathan R wrote:
>
> Here are the results;
> Code:
> --------------------
> /usr/sbin/dhcpcd-test wlan0
> info, wlan0: hardware address = 00:16:ea:71:94:dc
> info, wlan0: broadcasting for a lease
> debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
> debug, wlan0: waiting for 10 seconds
> debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
> debug, wlan0: sending DHCP_DISCOVER with xid 0x66468bb
> err, wlan0: timed out
> info, wlan0: exiting
>
> --------------------
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNtOVYAAoJEF+XTK08PnB5s2EP/RgIWC2+GdWwlNGoePYvF8i5
eWa7WIVt1oIX6NHq5UbNxJEdFZSOycOEYdPYtnwRIhLry6KLg9Ukn8JU6nKYnIy/
7Uj40q74Uo/FRikcgJf0Ky37CC3aU2zDHUFbZ/WOvA4Qr/ebQaZ9Jg3fCcqC6xsi
ManHpWjlA2KHdhbkrVph+DHDuWhj0ue+2uR5ssZdGpDA/xpnBHpniwN3EBMo7aRP
g8CHoIRsyRAiX4DaDVdWjVCRj8KKD6trNYgNNu6gWBSeRuZvOhRLOAvJW5KhIr2F
YQrIuxC1JXcFH9mkjkVtWaXkEXpF2t9ToVQcjvYqKyAn+kdsMWQ9KNKEUy+LD9lo
disxXLmUdWJx/OTOO12rjKowRFP94dLycuh9zx2UibHCukDqgSSP0WydAunSP867
xbFB8PBQgsAngicDiB6C3rvYA5fuSRrxe+Q1lbSWwWcs/MC6txwJt56AuIN/LDzo
Y0mGDpSBlm1mrIOQUMde7GAOqAywOerB2iAbVperU5WwxnbiDzjonB20crxhvgKJ
ZS3Bu9JtOJS/cHiZL8mjsfMulhtevKFuOeBYjpJlq9tgCge5LPkusucWoTCeVQrT
ja8yFJIdeSsJyqrZKoaWr6/KHzp6LlBnoagbkjb/1jsQnBQ9AclP96BV523z+qfi
fP5Jb7H2XENfWTeWM1Wc
=ToR7
-----END PGP SIGNATURE-----

Funny cause it works with eth0. So directly connected its fine, wirelessly, not fine

As to it being the router, no way. I have 4 other devices that are connected wirelessly and they are working fine. 1 openSUSE 11.4 laptop (my wifes). 1 openSUSE 11.4 desktop, 1 wii, and 1 bluray. My laptop is exactly the same as my wifes. In every detail. Same hardware, same OS.

If the wireless works Out of the Box normally

What happens if you boot a live cd?

Is your router configured to not associate IP addresses to wi-fi clients?

Reboot the router first, if it does not work, then
Try to set a static IP for the wireless card (can be done through the networkmanager)

Do you have some other wifi device? If so, does that device connect properly?

Can you also post output of


su -c lspci

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I should have mentioned that the /usr/sbin/dhcpcd-test command is useful
IF the wireless device is actually on the network… for example, IF it is
able to get the lower layers working. If you cannot get on the network at
all (WPA/WEP problems, out of range, other issues) then the test is
invalid. I’m assuming you can be on the network, but going back through
the posts I do not see evidence of that.

Good luck.

On 04/25/2011 01:36 PM, Knurpht wrote:
>
> Reboot the router first, if it does not work, then
> Try to set a static IP for the wireless card (can be done through the
> networkmanager)
>
> Do you have some other wifi device? If so, does that device connect
> properly?
>
> Can you also post output of
>
> Code:
> --------------------
>
> su -c lspci
>
> --------------------
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJNteBxAAoJEF+XTK08PnB5tpYP/1iyFaGVzqIqCgLnrjycC1/W
rpxr+HKpRd0Swo0GGC8UkJCnhCDnySgVkOnFv7pKraZQi7iBO05FejBITvKlsjvR
gVqikuO3r5KrnRBtt6KeSXPbLYjRbGVvK5LPw+L/OKtToqlkANyfZ4rrSgIZAfB7
rQZCpQE6iP/XGnks16Csjeyc8SKA9qMiKAqC1q6i1mDhWkaF2eJjleYirFM4cSIC
Fql0odIZmAcMF+nT4MZVaGlZzc5mMkOObIqzmtiVERZYWOeCTMxtYnMn7vI44tuB
Bwh6UTrQDxf07ejOTA5O+HSV/23lejUaE3yqAXYhLWEuWqRQRzqNFBlpiwmWRJNJ
I3WEkk3WdG8UeFZufFX3zcEBGx6ifV7ZsQ6dBMXGzsr2Lqvvl1bmNI5CpBPp0/YB
nKSM5a/scdN4lRavIb97sF45/FO8h5GANnzyU6VvntXCRtncCnBdfg/sqRSoFSns
6QlY3jTFGEJ1Qe7TnC1qM1lLd1JhRxSUPfvD6zs1B3Pl/0cAURDD7U8NO6dEw5sm
fk9jzm4uxPHDtxQtbozA6m1O8Q88zHFKwah7TxecPDiGx6JwQOzl2ZAZkMe2fhua
cUqsBuXusxeuJ6F0tFD7szZtMs6D019CdmMXC0lrq4JegTFxKljlMGxv5vP/Yu4r
GeglNtmEbR/D0tmNaYIy
=/X3c
-----END PGP SIGNATURE-----

I have 4 other devices that are connected wirelessly and they are working fine. 1 openSUSE 11.4 laptop (my wifes). 1 openSUSE 11.4 desktop, 1 wii, and 1 bluray. My laptop is exactly the same as my wifes. In every detail. Same hardware, same OS.

As to the rest, I’ll have to wait till I get home.

I reiterate
?

Or maybe you are filtering by MAC address? That would make more sense.

Strangely, the same thing. It authenticates but I don’t get a valid IP.

As I mentioned before lspci shows

02:00.0 Network controller: Intel Corporation WiFi Link 5100
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

of which its the intel network controller that we are working with.

I did reboot the router in fairness. No change.

I also tried assigning a static IP and then going back to dhcp. Still, no go. I even disabled the firewall in openSUSE. Nada.

And you have an identical machine and device connecting just fine? Same version of openSUSE?

Yes. My wifes computer is identical. Same hardware (just less ram) and same version of openSUSE.

Very odd
I’m sure you know enough about this subject that any advice I offer is less than useful.

But:

Was this machine working earlier with another OS or version of SUSE. Does it have another OS, that works?
I’m asking because I am wondering if you are using access control to assigned LAN IP and maybe don’t have the MAC added to the router settings.
Or, that if you use DHCP, you have enough of an address range available for all your connecting devices.

On 04/26/2011 12:06 AM, rodhuffaker wrote:
>
> bsilvereagle;2329541 Wrote:
>> Is your router configured to not associate IP addresses to wi-fi
>> clients?
>
> Or maybe you are filtering by MAC address? That would make more sense.

Run tcpdump to see the traffic.