wireless wont connect automatically-cant see my ssid

I have opensuse 12.1 kde. I have broadcom BCM4312, I installed b43-firware, using network management.

I see all the other ssid around me but i don’t see my ssid. my ssid is enabled to broadcast in my router but my wireless doesn’t pick it up.
Also even when i do get it connected by messing with setting in network management, my wireless doesn’t connect automatically. I’ve gotten connected but when i reboot it doesn’t automatically connect. the connect automatically is checked in settings. does system connection have to be checked as well?

maybe you can try wicd
I had same problem as you said
after change to wicd, all work fine
just remember do the following:

chmod 755 /etc/wicd/encryption

so you can choose the encryption type
You can get more info from my blog
黑眼珠2: 用 wicd 取代 NetworkManager](http://swyear.blogspot.com/2011/12/wicd-networkmanager.html)
Thought it’s writen in Chinese
but with many screenshots, I think you may understand