Wireless woes

Hi

I’m trying to connect my Toshiba Satellite laptop to a wireless lan or adhoc connection so that I can access the internet. I’m running Suse 11.0 with Gnome, and am relatively new to Linux.

Network Manager shows both wireless networks, Netgear (secure) and Home (adhoc unsecure) but fails to connect to them, timing out and in the case of the secure network asking again for more secrets (incidently it changes from WEP 128 to asking for Hex…).

Through other postings here, I’ve tried editing the connections through Network Manager to automatically connect, and have the WEP Key in place in the case of the Netgear connection.

By following the sticky post in this forum here is the info I’ve got:

/sbin/lspci

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
05:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)


/sbin/lspci -n

04:00.0 0200: 10ec:8136 (rev 01)
05:00.0 0280: 8086:4229 (rev 61)


dmesg (various cuts)

iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.23ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation

r8169: eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready
ACPI: PCI Interrupt 0000:05:00.0[A] -> GSI 18 (level, low) -> IRQ 18
PM: Writing back config space on device 0000:05:00.0 at offset 1 (was 40100102, writing 40100106)
ADDRCONF(NETDEV_UP): wlan0: link is not ready
NET: Registered protocol family 17

iwl4965: Detected Intel Wireless WiFi Link 4965AGN


dmesg afer trying to connect to wireless

wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:14:6c:67:ed:ea
wlan0: RX authentication from 00:14:6c:67:ed:ea (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:14:6c:67:ed:ea
wlan0: RX AssocResp from 00:14:6c:67:ed:ea (capab=0x471 status=0 aid=1)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:14:6c:67:ed:ea)
wlan0: switched to short barker preamble (BSSID=00:14:6c:67:ed:ea)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: disassociate(reason=3)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
wlan0: associate with AP 00:14:6c:67:ed:ea
wlan0: RX ReassocResp from 00:14:6c:67:ed:ea (capab=0x471 status=0 aid=1)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:14:6c:67:ed:ea)
wlan0: switched to short barker preamble (BSSID=00:14:6c:67:ed:ea)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: disassociate(reason=3)
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
SNIP (much more of the same)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: RX disassociation from 00:14:6c:67:ed:ea (reason=7)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: associate with AP 00:14:6c:67:ed:ea
wlan0: RX ReassocResp from 00:14:6c:67:ed:ea (capab=0x471 status=0 aid=1)
wlan0: associated
wlan0: CTS protection enabled (BSSID=00:14:6c:67:ed:ea)
wlan0: switched to short barker preamble (BSSID=00:14:6c:67:ed:ea)
iwl4965: Error sending REPLY_RXON_ASSOC: Already sending a host command
wlan0: disassociate(reason=3)
iwl4965: Error sending REPLY_SCAN_CMD: Already sending a host command
iwl4965: TX Power requested while scanning!


/usr/sbin/iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


If anyone can please help me or point me in the right dirrection that would be very much appreciated!

Cheers

Steve

First, two suggestions from uncle Google: you might need wpa-supplicant installed and configured and/or there should be only alphanumeric characters in your passphrase (no quotes, spaces etc.)
Now, from my own experience: every now and then my wireless connection gets screwed and this is what I do to restore it:

  1. go into YaST/Network Devices/Network Settings and delete the wireless connection.
  2. reboot (yeah, I’m using ndiswrapper, so no wonder I must use the Windoze three-finger-salute)
  3. enter YaST again and add a new wireless connection, probably named wlan0, filling in all the necessary info (the name of the driver - ndiswrapper or whatever, the ESSID, the encryption protocol, if any, the method of bringing the network up - I always select “on boot, via Network Manager”).
  4. I wouldn’t add anything else at this point. If the connection works, I’d wait until I get to the other AP (the encrypted one) and then repeat the procedure, adding another wlan connection, only naming it wlan1 now.

Thanks, I’ll see how that works :slight_smile:

Steve

You do need wpa-supplicant, but you probably have it. I did all my configuration through NetworkManager. I’m running SUSE-11.0 with kernel-2.6.25.18-0.2-default.


linux-nocz:/home/don # lsmod |grep iwl
iwl4965               139364  0 
firmware_class         27776  3 microcode,pcmcia,iwl4965
mac80211              220568  1 iwl4965

linux-nocz:/home/don # dmesg |grep iwl
iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.23ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation
iwl4965: Detected Intel Wireless WiFi Link 4965AGN
iwl4965: Tunable channels: 11 802.11bg, 13 802.11a channels
phy0: Selected rate control algorithm 'iwl-4965-rs'


linux-nocz:/home/don # dmesg |grep wlan
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:21:29:a7:c9:a3
wlan0: RX authentication from 00:21:29:a7:c9:a3 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:21:29:a7:c9:a3
wlan0: RX AssocResp from 00:21:29:a7:c9:a3 (capab=0x431 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present

linux-nocz:/home/don # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"miloulan"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:21:29:A7:C9:A3   
          Bit Rate=54 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:E9E6-1D5F-99
          Link Quality=100/100  Signal level=-37 dBm  Noise level=-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0