Wireless WEP key trouble

Hi,

it starts to drive me crazy why configured WEP key for wireless card doesn’t apply when interface is brought up >:(

eth1 is the wireless device
/etc/sysconfig/network/ifcfg-eth1 contains following assignments:

INTERFACETYPE=‘wlan’
STARTMODE=‘auto’
USERCONTROL=‘yes’
WIRELESS_AUTH_MODE=‘open’
WIRELESS_DEFAULT_KEY=‘3’
WIRELESS_ESSID=‘myessid’
WIRELESS_KEY=‘’
WIRELESS_KEY_0=‘’
WIRELESS_KEY_1=‘’
WIRELESS_KEY_2=‘’
WIRELESS_KEY_3=‘12345612345612345612345612’
WIRELESS_KEY_LENGTH=‘128’
WIRELESS_MODE=‘Managed’

If the eth1 interface is actived with ifup eth1 or at boot time, essid is properly set but encryption key is not - iwconfig displays “Encryption key: off”. What has so be done for WEP key to be also set ? Manual setting after every boot is very boring.
The system is openSUSE 11.1.

Thanks.

David

dunric wrote:
> Hi,
>
> it starts to drive me crazy why configured WEP key for wireless card
> doesn’t apply when interface is brought up >:(
>
> eth1 is the wireless device
> /etc/sysconfig/network/ifcfg-eth1 contains following assignments:
>> INTERFACETYPE=‘wlan’
>> STARTMODE=‘auto’
>> USERCONTROL=‘yes’
>> WIRELESS_AUTH_MODE=‘open’
>> WIRELESS_DEFAULT_KEY=‘3’
>> WIRELESS_ESSID=‘myessid’
>> WIRELESS_KEY=’’
>> WIRELESS_KEY_0=’’
>> WIRELESS_KEY_1=’’
>> WIRELESS_KEY_2=’’
>> WIRELESS_KEY_3=‘12345612345612345612345612’
>> WIRELESS_KEY_LENGTH=‘128’
>> WIRELESS_MODE=‘Managed’
>>
> If the eth1 interface is actived with -ifup eth1- or at boot time,
> essid is properly set but encryption key is not - iwconfig displays
> “Encryption key: off”. What has so be done for WEP key to be also set ?
> Manual setting after every boot is very boring.
> The system is openSUSE 11.1.

I don’t use WEP, but my WPA2 key is entered without me doing anything. My ifcfg
file has STARTMODE=‘onboot’. The other thing to try is putting your WEP key in
the “WIRELESS_KEY” keyword rather than WIRELESS_KEY_3, and getting rid of the
WIRELESS_DEFAULT_KEY data. I seem to remember that some system in the past
didn’t support multiple keys.

Larry

Thank You Larry, filling out the WIRELESS_KEY did the job. I’m thinking about bug reporting to openSUSE bugzilla.

dunric wrote:
> Thank You Larry, filling out the WIRELESS_KEY did the job. I’m thinking
> about bug reporting to openSUSE bugzilla.

Go for it.