Wireless stopped working

My laptop wlan connection did not start at boot-up today. I am running OpenSuse 11.2 on an Acer Travelmate 2490.

I checked the boot log and found:
<6> 11.965553] ath5k 0000:06:02.0: enabling device (0000 -> 0002)
<6> 11.965567] ath5k 0000:06:02.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
<6> 11.965658] ath5k 0000:06:02.0: registered as ‘phy0’
<6> 12.353607] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input8
<3> 12.852449] ath5k phy0: Invalid EEPROM checksum 0xb4f8
<3> 12.852643] ath5k phy0: unable to init EEPROM
<6> 12.852839] ath5k 0000:06:02.0: PCI INT A disabled
<4> 12.852862] ath5k: probe of 0000:06:02.0 failed with error -5

Does anyone know what the remedy is for this?

:frowning:

Did you run the kernel update

Sometimes drivers need re-installing after a kernel update

If an EEPROM failure suddenly appears, and powering off the machine (cold boot)
doesn’t help, it is usually hardware failure. The driver is not usually responsible.

What lwfinger said.

That’s un-good.

I don’t have a solution, but I can tell you I ran into the same issue with an Acer Aspire 5610Z and the Ath5k driver after applying patches from the latest Online Update and a reboot. When I regress back to the base 11.2 install, my wireless interface works - I’m using it to send this reply.

I don’t have the exact error, but I do notice an IRQ/PCI conflict reported during the boot sequence when I apply the latest kernel and driver.

Yes, I did take a kernel update. How should I proceed with a re-insallation of the wireless drivers?

The ath5k driver is in the kernel. Start the software installer, Configuration, repos, disable the update repo. Return to installer.
Now, search for ‘kernel-’, in the right panel, right click, pick All packages - update unconditionally. This may cause dependency conflicts, telling you other stuff has to be downgraded as well. Pick those options and accept. Reboot and you should be back in wifi land.

Start the softwareinstaller again, search for ‘kernel-’, tick kernel-default or -desktop (either one which is installed), right click and pick ‘Taboo’. Enter repo configuration and reenable update repo.

Brilliant, Knurpht, that did the trick! Many thanks!

The same problem (Acer Aspire 5110; Suse 11.2).
It’s working now.
Thanks
How to report this bug?

On 02/16/2010 05:26 PM, pangy07 wrote:
>
> The same problem (Acer Aspire 5110; Suse 11.2).
> It’s working now.
> Thanks
> How to report this bug?

As always - start from http://en.opensuse.org/Submitting_Bug_Reports

Thanks Knurpht!. I had the same problem (on an Acer Aspire 5610z), and regressing to the base install fixed it for me too. I’ve opened a bug report here.

Actually, the final steps – marking kernel-default as taboo – does not work for me. I can only mark packages that aren’t installed as “taboo”. I tried marking kernel-default as “protected” then enabling the updates repo and updating all packages, but that broke wireless again. It looks like selecting “update all” doesn’t respect the “protected” flag?

Has anyone else persuaded that part to work?

Anyway, I’ve gone back to the base install again and wireless is back. I guess I’ll just have to stick with an unupdated system until this bug is resolved.