Wireless stopped working ******** frustrated HELP *********

Hi there,

I’m on dell vostro 1400 with openSUSE 11.0 and GNOME desktop. I had installed my original driver with install_bcm43xx_firmware and it had worked fine. i dont know what happened but it stopped working. The only change is that I remember is changing login ID to knight from kight. I have deleted the old connection. I retried putting different Keys to my WEP router security (64bit) and it does not work. When I start my computer it recognizes my home network and says that the signal strength is 80%. But when I open firefox, nothing happens. I loose wireless connection and get a PackageKit Error (cannot refresh cache whilst offline). It never reconnects.

Here is some troubleshooting info.

ifconfig gives me
eth0 Link encap:Ethernet HWaddr 00:1C:23:FD:A5:24
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:150 errors:0 dropped:0 overruns:0 frame:0
TX packets:150 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10628 (10.3 Kb) TX bytes:10628 (10.3 Kb)

wlan0 Link encap:Ethernet HWaddr 00:1E:4C:AB:D3:51
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21e:4cff:feab:d351/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:41 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20595 (20.1 Kb) TX bytes:7143 (6.9 Kb)
wmaster0 Link encap:UNSPEC HWaddr 00-1E-4C-AB-D3-51-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

iwconfig gives me

wlan0 IEEE 802.11g ESSID:“home”
Mode:Managed Frequency:2.412 GHz Access Point: 00:13:46:C5:F7:EE
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:0000-0000-00
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
:slight_smile:

I’m at a point that I’m ready to reinstall openSUSE again. Please help !!!

what wireless card are you using? that might help us abit

well he is using bcm43xx so presumably the broadcom card.

what program were you originally using to connect? just knetworkmanager? have you checked to make sure your new user is in the ‘dialout’ group? does knetworkmanager say you are connected? if using wep, have you tried kinternet?

thestig wrote:

> ghostwind;1829800 Wrote:
>> what wireless card are you using? that might help us abit
>
> well he is using bcm43xx so presumably the broadcom card.

There are several Broadcom cards - some work, some don’t.


Graham Davis
Bracknell

looking at your ifconfig, I see the IP address assigned. Tells me, you have Wireless connected and looks good. Could be something u need to check on ur firefox. A proxy which doesnt exist??? Ping Google and see you can ping or atleast resolve hostname.

Try connecting another pc on the network and see if u can browse OK. Check your router and see if it can connect your ADSl connection.

do a route -rn and check if u have the default gateway set.

I realize that it is likely a broadcom card; however, knowing the specific network card could point to a specific/known problem

rbkumaran wrote:

>
> looking at your ifconfig, I see the IP address assigned. Tells me, you
> have Wireless connected and looks good. Could be something u need to
> check on ur firefox. A proxy which doesnt exist??? Ping ‘Google’
> (http://www.google.com) and see you can ping or atleast resolve
> hostname.
>
> Try connecting another pc on the network and see if u can browse OK.
> Check your router and see if it can connect your ADSl connection.
>
>

Is that reply for me or the OP?

Anyway, as I was saying, some Broadcom devices do not work; not only that,
they are not supported by b43. For instance, the only way to get BCM4310
working in 10.3 is to use ndiswrapper. There is no way - as yet - to get it
working in 11.0. Unfortunately, my fall-back position for my laptop is a
plug-in Ralink card - which was once recommended hardware - and this only
crawls along so I’m staying with 10.3 until a fix comes along.


Graham Davis
Bracknell
It was raining cats and dogs and I fell in a poodle. - Chic
Murray(1919-1985)

Hi guys, thanks for showing interest. Please remember that my wireless internet worked for a week or so and then something happened.

Here is more info…

hwinfo --wlan (for driver info) gives me

UDI: /org/freedesktop/Hal/devices/pci_14e4_4312
Unique ID: y9sn.jJPmv8UzN_1
Parent ID: qTvu.TkjeLK60Af8
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:0c:00.0
SysFS BusID: 0000:0c:00.0
Hardware Class: network
Model: “Broadcom BCM4312 802.11a/b/g”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4312 “BCM4312 802.11a/b/g”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x0007
Revision: 0x01
Driver: “b43-pci-bridge”
Driver Modules: “ssb”
Device File: wlan0
Features: WLAN
Memory Range: 0xfe8fc000-0xfe8fffff (rw,non-prefetchable)
IRQ: 17 (no events)
HW Address: 00:1e:4c:ab:d3:51
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v000014E4d00004312sv00001028sd00000007bc02sc80i00”
Driver Info #0:
Driver Status: ssb is active
Driver Activation Cmd: “modprobe ssb”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)


Another strange thing is that my ESSID keeps changing. My networkk name is ‘home’ and if you see my first post, it does show that. But now, ESSID is “”. So, now iwconfig gives me

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


About proxy settings: When I checked it my firefox properties, it said… “Use system proxy settings”. I changed to “Auto detect proxy settings” and restarted the computer. Did not work.

I also did ping Google and the reply was “unknown host”

**Doing a route -n gives me **
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
**
and doing route -n with ETHERNET (wired) connected gives me **
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0


Another difference i notice is that now my wireless network is not detected when I start my computer as I had stated in my first post.

Hopefully all this is enough for you guys to point me into a right direction.

I forgot couple things
I use GNOME with openSUSE 11.0 so I used YAST and then network settings (and this does say ESSID = ‘home’). I also right click on the network symbol and edit network connections.

I dont know how to check my user in ‘dialout’ group. How do I do that ? I also have never heard knetworkmanager and kinternet. Probably because I’ve never used GNOME ?

parind555 wrote:
> Hi guys, thanks for showing interest. Please remember that my wireless
> internet worked for a week or so and then something happened.
>
> Here is more info…
>
> HWINFO --WLAN (FOR DRIVER INFO) GIVES ME
>
> UDI: /ORG/FREEDESKTOP/HAL/DEVICES/PCI_14E4_4312
> UNIQUE ID: Y9SN.JJPMV8UZN_1
> PARENT ID: QTVU.TKJELK60AF8
> SYSFS ID: /DEVICES/PCI0000:00/0000:00:1C.1/0000:0C:00.0
> SYSFS BUSID: 0000:0C:00.0
> HARDWARE CLASS: NETWORK
> MODEL: “BROADCOM BCM4312 802.11A/B/G”
> VENDOR: PCI 0X14E4 “BROADCOM”
> DEVICE: PCI 0X4312 “BCM4312 802.11A/B/G”
> SUBVENDOR: PCI 0X1028 “DELL”
> SUBDEVICE: PCI 0X0007
> REVISION: 0X01
> DRIVER: “B43-PCI-BRIDGE”
> DRIVER MODULES: “SSB”
> DEVICE FILE: WLAN0
> FEATURES: WLAN
> MEMORY RANGE: 0XFE8FC000-0XFE8FFFFF (RW,NON-PREFETCHABLE)
> IRQ: 17 (NO EVENTS)
> HW ADDRESS: 00:1E:4C:AB:D3:51
> LINK DETECTED: NO
> WLAN CHANNELS: 1 2 3 4 5 6 7 8 9 10 11
> WLAN FREQUENCIES: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447
> 2.452 2.457 2.462
> WLAN ENCRYPTION MODES: WEP40 WEP104 TKIP CCMP
> WLAN AUTHENTICATION MODES: OPEN SHAREDKEY WPA-PSK WPA-EAP
> MODULE ALIAS:
> “PCI:V000014E4D00004312SV00001028SD00000007BC02SC80I00”
> DRIVER INFO #0:
> DRIVER STATUS: SSB IS ACTIVE
> DRIVER ACTIVATION CMD: “MODPROBE SSB”
> CONFIG STATUS: CFG=NO, AVAIL=YES, NEED=NO, ACTIVE=UNKNOWN
> ATTACHED TO: #18 (PCI BRIDGE)
> *************************************************************
> ANOTHER STRANGE THING IS THAT MY ESSID KEEPS CHANGING. MY NETWORKK NAME
> IS ‘HOME’ AND IF YOU SEE MY FIRST POST, IT DOES SHOW THAT. BUT NOW,
> ESSID IS “”. SO, NOW IWCONFIG GIVES ME
>
> WLAN0 IEEE 802.11G ESSID:""
> MODE:MANAGED FREQUENCY:2.412 GHZ ACCESS POINT:
> NOT-ASSOCIATED
> TX-POWER=27 DBM
> RETRY MIN LIMIT:7 RTS THR:OFF FRAGMENT THR=2352 B
> ENCRYPTION KEY:OFF
> LINK QUALITY:0 SIGNAL LEVEL:0 NOISE LEVEL:0
> RX INVALID NWID:0 RX INVALID CRYPT:0 RX INVALID FRAG:0
> TX EXCESSIVE RETRIES:0 INVALID MISC:0 MISSED BEACON:0
> ************************************************************
> ABOUT PROXY SETTINGS: WHEN I CHECKED IT MY FIREFOX PROPERTIES, IT
> SAID… “USE SYSTEM PROXY SETTINGS”. I CHANGED TO “AUTO DETECT PROXY
> SETTINGS” AND RESTARTED THE COMPUTER. DID NOT WORK.
>
> I ALSO DID PING ‘GOOGLE’ (HTTP://WWW.GOOGLE.COM) AND THE REPLY WAS
> “UNKNOWN HOST”
>
> **DOING A ROUTE -N GIVES ME
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0
> lo
>
> AND DOING ROUTE -N WITH ETHERNET (WIRED) CONNECTED GIVES ME
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0
> eth0
> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0
> lo
> 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0
> eth0
>
> **************************************************************
> Another difference i notice is that now my wireless network is not
> detected when I start my computer as I had stated in my first post.
>
> Hopefully all this is enough for you guys to point me into a right
> direction.

First of all, I am writing this message using a BCM4312 - the same
interface that you have. It works very well

The first thing is to investigate what information is being logged. In
a console, please enter the commands ‘dmesg | grep b43’ and ‘dmesg |
grep wlan0’ and post the results.

Larry
**

dmesg | grep b43 gives me

b43-phy0: Broadcom 4311 WLAN found
input: b43-phy0 as /devices/virtual/input/input10
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio
b43-phy0: Radio hardware status changed to DISABLED
b43-phy0: Radio turned on by software
b43-phy0: The hardware RF-kill button still turns the radio physically off. Press the button to turn it on.

and dmesg | grep wlan0 gives me

ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:11:95:56:7a:f3
wlan0: RX authentication from 00:11:95:56:7a:f3 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:11:95:56:7a:f3
wlan0: RX AssocResp from 00:11:95:56:7a:f3 (capab=0x421 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: disassociate(reason=3)
wlan0: no IPv6 routers present
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:13:46:c5:f7:ee
wlan0: RX authentication from 00:13:46:c5:f7:ee (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:13:46:c5:f7:ee
wlan0: RX AssocResp from 00:13:46:c5:f7:ee (capab=0x431 status=0 aid=2)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:13:46:c5:f7:ee)
martian source 255.255.255.255 from 192.168.0.1, on dev wlan0
martian source 255.255.255.255 from 192.168.0.1, on dev wlan0
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=414 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=394
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=454 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=434
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
martian source 192.168.0.255 from 192.168.0.101, on dev wlan0
wlan0: No ProbeResp from current AP 00:13:46:c5:f7:ee - assume out of range
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
SFW2-INext-DROP-DEFLT IN=wlan0 OUT= MAC= SRC=192.168.0.102 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44

parind555 wrote:
> dmesg | grep b43 gives me
>
> b43-phy0: Broadcom 4311 WLAN found
> input: b43-phy0 as /devices/virtual/input/input10
> b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
> Registered led device: b43-phy0::tx
> Registered led device: b43-phy0::rx
> Registered led device: b43-phy0::radio
> b43-phy0: Radio hardware status changed to DISABLED
> b43-phy0: Radio turned on by software
> b43-phy0: The hardware RF-kill button still turns the radio physically
> off. Press the button to turn it on.

Your wireless is turned off by some kind of switch. How does your machine handle
this? Mine has a slide switch on the front edge. Others have a push button in
the middle of the top of the keyboard. Others use a function key.

On some models, Windows gets in the way even when running Linux. See ‘Broadcom
Wireless on Suse 11/XP Home system - openSUSE Forums’
(http://tinyurl.com/5vk6co) for details.

Larry

Hey Larry,

After all this it comes down to a switch. Guess I’m the one to blame for. I did not know my laptop. This switch is right next to the status indicators on the left edge of the laptop. I never paid attention. Somehow it must have gotten changed. Thanks.

parind555 wrote:
> Hey Larry,
>
> After all this it comes down to a switch. Guess I’m the one to blame
> for. I did not know my laptop. This switch is right next to the status
> indicators on the left edge of the laptop. I never paid attention.
> Somehow it must have gotten changed. Thanks.

Things like that happen to everyone. The main lesson is ALWAYS to look in the
dmesg output whenever there is a problem. You find out a lot there.

Larry