Wireless stopped working (Broadcom wireless adaptor)


I had a version of openSUSE 13.1 installed and working fine in a dual boot system. Then, about a month ago wireless stopped working. No option to connect wirelessly even appears any more.

After the initial install I had a lot of trouble with a slow and unstable wireless connection. Thee seems to be a lot of problems with Broadcom BCMA4313 802.11bgn wireless adaptors. I’m quite new to openSUSE and Linux based systems. So at that time a very knowledgeable friend solved the problem by doing something to the kernel (I think their solution was based on advice that has appeared before on forums).

Anyway, suddenly wireless seems to have disappeared as a connection option. I don’t really know where to begin to solve this. I did an “/sbin/lspci -nnk” and the Network Controller is BCM 4313 802.11bgn Wireless Adaptor [14e4:4727], so I guess it’s still recognised.

I’d really appreciate it if someone could help with a solution or even advise me on what I should do next?

Does the system have wired connection at all?

The BCM43 series requires a non-oss driver from Packman, please post the output of:
zypper se -si broadcom

Hi Miuku

Thanks for your reply. No, there is no wireless connection. It doesn’t even appear as an option.

Here is the output of zypper se -si broadcom :

Download (curl) error for ‘http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/repomd.xml’:
Error code: Connection failed
Error message: Could not resolve host: dl.google.com

Abort, retry, ignore? [a/r/i/? shows all options] (a):

You misunderstood me - I was asking if you had a wired connection, not wireless connection.

If possible, plug the machine into a wired connection and run the zypper command for me.

Apologies Miuku

I’ve just tried a wired connection. Even though a cable was definitely plugged in it says “cable unplugged”, so there’s no wired connection either.

The system I have is a dual boot with Windows 8, and the Windows internet connections are working fine, so I don’t think it’s a problem with the adaptor.

Hi Miuku

I got a very limited wired connection and ran the zypper se -si broadcom command. Here’s the output:

[INDENT=3]Loading repository data…[/INDENT]
[INDENT=3]Reading installed packages…[/INDENT]
[INDENT=3]No packages found.[/INDENT]

It’s strange, becuase wireless used to work. Maybe an update did something. Would you know what I can do next to try fix it? I’d really appreciate any advice you can give.


What if you select advanced options in the boot menu and then boot the 3.11.10-21 kernel, wich still should be there?

Thanks. Everything is working when I use the 3.11.10-21 kernel. Should I just stick to using that or do you know of a way to fix the problem with the updated kernel?

If I were you, I would add the Packman repository and install broadcom-wl-kmp-desktop and reboot.

Do you know how to add community repositories?

Sorry, I don’t. Could you advise me or point me in the direction of a tutorial?

Yast -> software -> repositories -> add -> community repositories -> checkmark Packman -> ok and finish.

When it asks to trust the repo, choose Always.

Then you can do this in two ways:

Open a terminal and type: sudo zypper install broadcom-wl-kmp-desktop
Go to Yast, software, install software and type it into the search box. Reboot after install.

I did that and now everything is working great in the recent kernel as well.

Thanks so much for all your help and time Miuku:)

Glad to here that. In case you wonder, your friend probably built and installed the broadcom module from source, that’s why it didn’t work when a new kernel was released in December. Now that you have Packman they will realease a new kernel module whenever OpenSuse releases a new kernel. And in addition to that you now also have access to all the software in the Packman repo, a highly trusted source I would say.

Thanks, that’s useful to know.

This is a general question, but are there any other useful packages you would recommend installing?

Now you are starting to ask for the impossible, how can anyone but you yourself possibly know what your needs are?
Ask yourself what you would like to have and search for it in yast, very likely there will be something for you, this is not windows.
Go to Yast software management, at the top are some tabs, one should probably say show in English, select Patterns or Package groups, you’ll be amazed if you haven’t looked there before.

Depends on your needs - mp3 playback for example is crippled by default due to patents.

Packman repository, which you added, contains the necessary packages to enable playback of many patent ridden formats. You might also take a peek here; http://opensuse-guide.org/

It has some information and basic stuff about the distro, most of it should be up to date.