wireless range of less than 3 feet

Hi,
I thought I would drop a few findings relating to a strange problem I don’t have the answer to.

I have installed both Ubuntu and now OpenSuse (alongside Windows XP) on a thinkpad T40.
I own a linksys WRT54G2 wireless router.

Windows XP runs fine, and connection to the wireless network is fine everywhere in the house.

however the first time on Ubuntu and now on Opensuse 11.2, the laptop needs to be within 3 feet of the router in order to connect to the wireless network!

Strange thing is that the laptop can see the network from anywhere in the house (with a signal strength carying between 60 and 90%) - however impossible to connect.

Suse is running the ath5k driver for the internal network card.

If anyone has any ideas regarding the cause and solution to this problem, I’d be keen to hear them!

apart from that I have to say i’m quite pleased with the latest Suse release. (which doesn’t randomly freeze like ubuntu!!)

BL

Seeing network requires reception only. Using network requires transmission as well.

Since the hardware works in Windows, the most suspicious is the driver.

Search for you hardware in Linux in google or opensuse’s web site.

Also try to update router’s firmware.

On 12/31/2009 07:36 AM, backlash2k wrote:
>
> Hi,
> I thought I would drop a few findings relating to a strange problem I
> don’t have the answer to.
>
> I have installed both Ubuntu and now OpenSuse (alongside Windows XP) on
> a thinkpad T40.
> I own a linksys WRT54G2 wireless router.
>
> Windows XP runs fine, and connection to the wireless network is fine
> everywhere in the house.
>
> however the first time on Ubuntu and now on Opensuse 11.2, the laptop
> needs to be within 3 feet of the router in order to connect to the
> wireless network!
>
> Strange thing is that the laptop can see the network from anywhere in
> the house (with a signal strength carying between 60 and 90%) - however
> impossible to connect.
>
> Suse is running the ath5k driver for the internal network card.
>
> If anyone has any ideas regarding the cause and solution to this
> problem, I’d be keen to hear them!
>
> apart from that I have to say i’m quite pleased with the latest Suse
> release. (which doesn’t randomly freeze like ubuntu!!)

As you note, this is not an openSUSE problem - it is a problem with the ath5k
driver. The developers for that driver submit fixes regularly to the
wireless-testing kernel tree. You can tap into those changes by installing the
compat-wireless package for your kernel.

If you want to get the latest bleeding-edge wireless code, you should use git to
get a copy of the wireless-testing tree and run a 2.6.33-rc2 (at the moment)
kernel, or get a copy of the bleeding-edge compat-wireless source.

Another option is to post an inquiry on the mailing list at
linux-wireless@vger.kernel.org. Please note that your inquiry will be totally
ignored if you do not provide much more specific info than you did here.