wireless problems with opensuse 12.1

I have installed openSUSE 12.1 last weekend en every think is working.
Also after the reboot of the installation.

after an shutdown of the system the wireless card is not responding any more.
with the cmd IFUP wlan0 is telling me that the interface is up but no connection with the internet.
it’s get a ip address and that’s it.

after i changed the configuration in Yast from automatic after boot in manually and deselect ip6 then after a shutdown the wireless card is responding with the cmd ifup wlan0.

I want it up automatic after system start but so far i did not succeed in this.
But the question is how? can someone give me the answers to this? :frowning:

Wireless is usually best managed with network manager
What device?

Post result of

/sbin/lspci -nnk

my card is a ralink rt2800 (linksys wpn600) and even with networkmanager i didn’t get i working in automatic mode.

I have rt2800
It works out of the box

Please post the requested info

I noticed that problem when I was running 11.4. I haven’t seen it with 12.1, but that might be because I have mainly been using NetworkManager.

With 11.4, I found that the problem was due to “dhcpcd” caching the dhcp information across reboots, instead of doing a new “dhcp” request. I solved that in 11.4, by setting
in “/etc/sysconfig/network/dhcp”. You can do that in Yast settings for “/etc/sysconfig”.

If you want to try that, then be sure to also set
because that works around a bug in “dhclient” (see Bug732910 for details).

I’m not sure if that will actually solve your problem, which could also be hardware related.

i have the solution by the user nrickert, it seems that the dhcpd after booting the pc is not working.
with the change of DHCLIENT_BIN=“dhclient” the card is working.
de dhcpd is a weak piont within opensuse and needs improvment by SuSe.
i thank you for your quick repons on the problem.

the solution is working! and i thank you for your quick repons on the problem.

Make sure that you set that DEBUG option, as I mentioned above. Otherwise it will stop working.

I changed this also but i forgot to write it down in the message.
A other think what i have noticed is that when the card is not working after boot, the card is up and running with the cmd. rcnetwork restart.
when you take a look at the boot message you shell see that the listing stop by activating the dhcpd.
by modifying the file /etc/sysconfig/network/dhcp in Yast you have to reboot the system, this can also be done by the cmd rcnetwork restart.:slight_smile:
above the story in a nutshell by a default system without the modification of the file /etc/sysconfig/network/dhcp.
Untill now the modification of the file /etc/sysconfig/network/dhcp works fine.:slight_smile:

I am running Opensuse 12.1 KDE on Macbook Pro. I could not fix wireless yet. The Networkmanager option for wireless if grayed out. If I see /sbin/ifconfig it does not show anything other than eth0 and lo. wlan0 or eth1 for wireless is not listed anywhere. The output of /sbin/lspci shows the following :

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)
Subsystem: Apple Computer Inc. Device [106b:008d]
Kernel driver in use: b43-pci-bridge

I have all boradcom drivers installed. Tried several solutions suggested in different threads but to no avail. Wireless works with mac perfectly. No hardware issue.

I appreciate if you help me resolve the issue.

Thanks in advance.

Try wl then

Install Broadcom Drivers from Packman - Blogs - openSUSE Forums

Thanks for the reply.

Yes, I have installed broadcom-wl and broadcom-wl-kmp-default as you have suggested in your thread. It still does show up in /sbin/ifconfig or in NetworkManager. I tried configuring manually also using Traditional ifup method. None have worked so far.

I appreciate further suggestions.

Thanks in advance.

02:00.0 Network controller [0280]: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)

Please post result of

uname -a
rpm -qa | grep kernel
rpm -qa | grep broadcom
/sbin/lspci -nnk

I only need the wireless part of this